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FILE MANAGEMENT IN DOS & WINDOWS 

In today's work, every text, data and calculations are being performed on computers. 

Each computer is having a lot of information in the form of files, which are the basic unit of 

storage. Each file has its own specifications. Every software even as the MS-DOS and 

WINDOWS are stored in files which are read into the computer's memory when the system 

starts. There are various types of files, each having its unique name and location in addition 

to a group of attributes. Most of the files also have an extension. The file's name and 

extension is referred to as the filename. It is necessary to manage these files in a suitable 

order. Each software has its own File Manager. Now-a-days MS-DOS and WINDOWS are 

very popular and useful softwares with various facilities. 

1.0 FILE MANAGEMENT IN MS-DOS 
MS-DOS also manages the flow of information to and from the various parts of the 

computer system like other operating systems. It performs many tasks. One of them is to 

Manage Files and Directories. Organizing the files in directories and subdirectories on a disk 

is like organizing the documents into file folder and then storing them in the drawers of a file 

cabinet. 

1.1 Directory Tree 
Every disk has at least one directory. It is called the root directory. User can create 

subdirectories of the root directory to organize files. Directories and subdirectories form a 

structure called a directory tree, as shown in the following example; 

User can add any directory at any level of the structure. Number of files and 

directories in the root directory can not exceed 512. MS-DOS runs slowly if number of files 

and subdirectories in one directory is more than 150 or so. 

Directories Directories and Subdirectories 

A:--- C:--- 

 Text I  Dos 
I  Spreads I Art 

Work 
Home 
School 
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File Management in DOS and Windows 

1.2 Path 

The path specifies the location of a file within the directory tree. It is assumed that MS- 

DOS travels, starting from the root directory, to get to files in another directory. For example, 

let the drive C has the following directory tree; 

C: 

DOS 

ART 
• 

WORK 

HOME  I FIG.MSP 

SCHOOL 

To get the file in the Home directory, MS-DOS must go through the following 

directories: root(\), ART, and Home. e.g. CART\HOME\FIG.MSP 

1.3 Viewing Directories 

To see a list of files in any directory on any disk, use the 'dir' command. The simplest 

form of this command displays a list of files in the current directory. By changing the 

commands, user can do the following; 

C : > DIR T*.*, View only certain files named with a letter T in the directory. 

C : >DIR/P View a directory listing, one screen at a time. 

C : > DIR WR.DAT File with the name WR.DAT will be displayed only. 

After making the subdirectories, user can put different files under different heads. 

1.4 Working With Files 
Files organize information that the Computer uses. There are a various types of files. 

Each file has a unique name and location in addition to a group of attributes to describe it. 
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File Management in DOS and Windows 

1.4.1 Filenames  

Every file has a name. Most files have an extension. The name always appears first 

and the extension is separated from it by dot '.' e.g. ABC.Ext. Each file has a name for 

identification e.g. COMMAND.COM  file contains MS-DOS Commands and MOUSE.COM  file 

contains information about the system when user uses a mouse. The name of the file should 

have: 

not more than eight characters. 

only the letters A to Z, numbers 0 to 9 , and the special characters (e.g. (-), ^, $, I, 

#, %, and, _,{ }, ( ), @, ' and " ) can be used. No other special characters are 

acceptable. 

1.4.2 File Extensions  

Extensions help to identify the type of file, MS-DOS uses the following extensions: 

.EXE Or .COM for files that contain Programs. 

.SYS for file that contain information about the hardware. 

.BAT for files containing lists of commands that MS-DOS carries out as a set. 

User can choose any extension that help them to identify the file. The extension must 

not contain more than three characters. The filename restrictions regarding characters and 

spacing also apply to extensions. 

1.4.3 Types of files  
Much of the information stored in files is text, such as letter, punctuation and special 

characters. Different tasks can be performed with different types of files, so it is important to 

be able to recognize the types of files and the applications ment for. 

Program Files It contains the programs at which the Computer runs. Program files 
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usually have an ,EXE or .COM extension. 

Specialized data It is common for a program to produce files that contain codes which 

can be used only by that program. e.g. when user create a 

spreadsheet data file, the spreadsheet program saves the file in a 

format that can be read by it only. It has generally .DAT extension. 

Unformatted text Unformatted text files contain only files' text. Almost all Computer 

programs, including MS-DOS, use a System called ASCII to represent 

text. Files of this type often have a . TXT extension. 

System files System files contain information about hardware and are sometimes 

called device drivers. These files usually have a .SYS extension. 

Batch Programs Batch Programs are unformatted text files that contain MS-DOS 

commands. If the user often type the same set of commands to start 

a program, they can put them into a batch program. Instead of typing 

the commands each time, user can use the batch program. Batch files 

always have a .BAT extension. 

1.4.4 File Size, Date and Time  

MS-DOS stores information about the size of files and the date and time at which they 

were created or modified. User can view this information by giving the DIR Command. 

e.g. MS-DOS display the following information in response to a DIR Command: 

Volume in drive A is LARK 
Volume serial number is IE 51-21 FB 

DIRECTORY of A:\  
BACKUP COM 36880 12-07-90 12.00a 

Disk COM 13096 15-06-92 11.30a 

KEYS COM 96832 10-07-94 1,0.00a 
FORMAT BAT 10396 5-04-97 12.00a 
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1.4.5 Usina Wild Cards 

If the user want to perform the same task for a group of files, they do not have to use 

the same command again and again. They can use wildcards to specify groups of files. A 

wildcard acts as a substitute for a name or extension. There are two wildcards in MS-DOS. 

The asterisk (*) represents a whole word or a group of characters. 

The question mark(?) represents a single character. 

The following commands will give the outputs as follows: 

DIR A : *.COM--- View a list of all files that have a .COM extension. 

DIR A : DIR/W--- View a list of all files across the width of the screen in several columns. 

DIR A :*.COM/W-- View only filenames that have the .COM extension across the width of 

the screen. 

DIR A : C*.*/W--- View all files that have names beginning with letter C (width-wise).  

COPY Y*.TXT A :---All the files beginning with letters Y and with extension TXT will be 

copied in drive A with the same names. 

DEL MK*. FOR--- It will delete all the files beginning with the letters MK and 

extension FOR. (Be careful about it). 

DIR A:???.*/W--- MS-DOS lists files that have names of upto three letters, regardless of 

the name or extension. 

1.4.6 Using Wildcards to Match Files  
User can use wildcards to match one file or group of files with another. e.g. to change 

all files with A.BAT extension to A.BAK extension on a disk in drive A, use the rename 
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command. 

REN A : *.0AT '.BAK 

It will rename all files on a disk in drive A with .BAT extension keeping their original 

names but changing their extensions to .BAK. Use the following command also: 

COPY A: FM*.BAT B: MN*.BAT 

REN C:??AB.FOR ??CD.FOR 

HEN C:???.DAT A:AA?.DAT 

DEL A: ".DAT 

DEL B : A??.OUT 

1.4.7 Viewing Text Files  

The files in MS-DOS can be viewed by the command TYPE. 

TYPE - MS-DOS displays the entire file on the screen. 

TYPE A: LIST.TXT-- All the text of this file will appear on the screen without stopping. 

User can temporarily stop the display of a file by pressing CTRUS or the Pause Key 

at Scrolling. 

To start again, Press any key except PAUSE. 

TYPE A: LIST.TXT 1 MORE --> View the file - one screen at a time. 

Press CTRUC or CTRUBreak, which cancels the type command. 

1.4.8 Copying files  

COPY A: A.FOR B:A.FOR 

COPY A:P.TXT B: 

COPY *.D6S B: 

COPY A:AN?PT.DOC B: 
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COPY A:A.FOR B:B.FOR (Rename) 

1.4.9 Combining Text Files  

To combine two or more unformatted text files into one file, give the command: 

COPY PROB.TXT + DOBTXT PRODOB.TXT 

COPY A:SCENE1.TXT + A:SCENE2.TXT B:ACT.TXT 

1.5 Delete Commands: 

The user can delete a single file, select groups of files, or all files in a directory or on 

file handling a disk by giving the command: 

DEL A.FOR 
DEL *.DAT 
DEL PR*.TXT 
DEL P*.* 
DEL b:*.* 
DEL A:???.DAT 
DEL CATMP\*.* (MS-DOS prompts to confirm the deletion) 
DEL CATMP (Same as above). 

1.5.1 Deleting Files by Using MS-DOS Shell 

Shell: To delete a File(s) 

From the file list, select the file(s) to be deleted. 

From the File menu, choose delete or Press the DEL Key. The Delete File confirmation 

dialog box appears. (User can suppress this confirmation message by choosing 

confirmation from the option Menu). 

Choose the Yes button. 
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1.5.2 Recovering Deleted Files  

To recover an accidentally deleted file, use the undelete command as follows: 

Undelete A:TEMP.EXE. 

Undelete A: *.BAT 

Undelete A: *.* 

when MS-DOS attempts to recover files, and deletion tracking is not installed, user 

is prompted to type the first letter of the filename for each file which they want to recover. 

Undelete works best when Mirror program is installed in MS-DOS. It keeps track of the area 

of the disk that was used by the deleted files. If user wants MS-DOS to keep track of deleted 

files on a disk, they should use Mirror program by the Command. 

(i) Mirror /ta 

The drive a letter must follow the /t Switch. However, do not use a Colon(:) with the 

drive letter 

For drive A and C both give 

Mirror / ta /tc 

After installing Mirror Program, when the user delete a file on drive A or C, a file called 

PCTRACKR.DEL is created in the root directory of that drive. This is a system file that 

contains the information which undelete needs to recover the delete file. Each time when user 

delete a file, PCTRACKR.DEL is updated with information about that file. 

MIRROR /tc - 500 (Maximum number of deletions to be tracked to 500) 

o. Using Mirror may slow down the system. If deleted files are large in number. 

o. Also User can put the mirror command in AUTOEXEC.BAT file, specifying the /t 

switch for each drive in the system. 
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1.5.3 Comparing Files  

User can see whether two files or groups of files have the same contents by using the 

FC command as follows: 

FC A: MA.DAT B: MA.DAT 

MS-DOS compares the files and displays differences. 

FC/A A: MA.TXT B: MA.TXT 

The /a switch in this example abbreviates the output for the comparison of two text files. It 

displays the filename, the line of text that begins a set of differences. 

FC/A A:MA.TXT B: MA.TXT > Compare.TXT 

Through this command, the user can stores the results in a file rather than displaying them 

on the screen. 

1.6 File Attributes: 
Every file can have four qualities associated with it. These qualities are called file 

attributes. 

Archive attribute(a) Used with the backup, xcopy, and other commands to control 

which files are backed up. 

Read-only attribute(r) Prevents a file from being changed or deleted. User can only 

read on terminal. 

Hidden attribute (h) Prevents MS-DOS from displaying a file in a directory list. The 

file remains in a directory, but the user cannot use the file 

unless he knows its filename. This attribute is useful if user is 

working on confidential files. 
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o System attributes (S) designated a file as a system file. File with the system attributes 

are not shown in directory listings. 

1.6.1 For Viewing the Attributes of the Files  

Command "ATTRIB A:CONFIG.SYS" will give the output as 

"a r CONFIG.SYS" if a and r attributes are present with this file. 

ATTRIB C:\*.* will give the attributes of all files in the root directory. 

Changing the Attributes of the File  

attrib +r config.sys - will have read only attribute. 

attrib -r config.sys - will remove read only attribute. 

attrib -r b:gem.xls - will remove read only attribute. 

1.7 Finding Text Within a File 

To view the lines of a file that contain specified text, use command 

Find "Area code" A.TXT 

To view only the number of lines that contain the specified text , include the /c switch: 

Find "Error" output.Txt/c 
(The capitalization and spacing of the text specified must be identical to the text in the 

file.) 

User can't search more than one file at a time, but it is possible in the find 

command. 

Find "area code:111" phone.txt addr.txt 
The results of find commands can be stored in a separate file by 

Find "area code" phone.txt> Ninf.num 
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All the results from Find command will store in a file Ninf.num. 

1.7.1 Getting File information by using MS-DOS Shell  

Using MS-DOS shell, the user can get information about a file, its directory and the 
disk. 

Shell - To get information about a file: 

From the file list, select the file. 

From the option Menu, choose show Information 

The show information dialog box appears, having four sections - File ,Select, 

Directory, and Disk. 

2.0 FILE MANAGEMENT IN WINDOWS 3.1 
It is little hassle to keep the files organized and updating in DOS. File management 

task via the DOS interface require exacting attention to syntax and spelling, both of which are 

sometimes difficult or tedious to remember. One of the more gruelling jobs in DOS is copying 

files between directories. 

2.1 Starting The File Manager 
There is a very good facility as File Manager in Window 3.1 with all the procedures 

required for managing the Files. To run the File Manager, open the Main group and 
double-click on the File Manager icon. This will bring up the File Manager's initial screen. As 

the user will open Window in File Manager ,the window's size may be different, since the File 

Manager has an option that saves its setup, just as the Program Manager does, when user 

exits Windows. It can be adjusted according to user's requirement. 

The main File Manager window and a child window within it show the directories on 

the hard disk. Whenever user requests to view a directory or disk drive's contents, they'll be 

displayed in a child window. User can open as many child windows as they want, each 
showing different (or identical) directories and/or drives. Then copy and move files between 

them, delete files, or run programs are possible. This section outlines how to carry out each 
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procedure. 

2.1.1 Displaying Directories and File Views 

File Manager provides a graphical representation of files and directories and help the 

user to organize and simplify file maintenance. To run the File Manager, the directory window 

for the current drive will be on screen. It lists all the directories on the current drive and their 

contents. The window is split into two panes, the left side for the directory tree and the right 

side for the directory contents. If the window isn't split, open the view menu. There are three 

choices of view. 

Tree and Directory - displays both panes. 

Tree Only - displays only the tree pane. 

Directory Only - displays only the directory (file) pane. 

For the discussion, choose Tree and Directory. See the tree on the left, and on the 

right the contents of whatever directory is currently selected (highlighted) in the tree. 

2.1.2 The Tree Pane  

The directory window is divided by the split bar. The left side of the window displays 

the structure of the current drive, or the directory tree. The tree is a graphical representation 

of the disk layout. Each file folder icon symbolizes one directory, and the straight lines 

connecting them indicate how they're related. The name of each directory appears after the 

icon . If user has more directories than can be seen at one time, the window will have a 

scroll bar which user can use to scroll the tree up and down. To see as many directories as 

possible at one time, maximize both the File Manager and the child windows. It makes 

working with a directory tree much simpler. 

2.1.3 The Status Line 

Status bar displays information about the current drive and directory and other 

information that helping explaining the task user is performing with File Manager. A status 

line at the bottom of the window displaying the amount of available room the drive has and 

the number and size of the files listed. User can turn this on or off. Turning it on frees up a 
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little more space for displaying directories and files. Choose Options --> Status Bar to change 

the setting. 
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Fig. 2.1: File Manager Screen, showing the directory structure with Tree Expension. 

2.1.4 Switching Drive  
To switch drives, simply click on the appropriate drive icon. If user wants to 
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choose a floppy drive icon, then insert a floppy disk in the selected drive . Once the drive 

is changed, the File Manager examines the new drive and displays its directories in the 

tree pane. Usually the floppies will have only one directory (the root) so user can see only 

one file folder. 

2.2 Working With Directories 
Once the correct drive has been selected, user can work with the various 

directories and files it contains. Some file folders in the directory tree window have a plus 

sign(+) in them. The plus indicates that there are additional subdirectories attached to the 

directory, and that these are not currently showing. A minus indicates that all the 

immediate subdirectories are currently visible. 

2.2.1 Creating a Directory  
Creating a directory is easy than creating directories from the DOS command line. 

Because of the graphical nature of the directory tree, it's much easier to visualize on the 

screen. For creating a new directory, user can employ the file commands or mouse 

procedures explained later to copy or move files into it: 

From the tree pane, select the directory under which user wants to create a 

subdirectory. If user select the root, then the directory will be created directly. 

Choose File --> Create Directory. A dialog box will appear. 

Type in the name of the new directory and click on O.K. 

2.2.2 Deleting a Directory  
Deleting a directory in DOS is a pain. User has to remove all the files first, then 

delete the directory. In the File Manager it's much simpler . User can do it in one step. 

But since it's so easy, User has to be careful. One false move wiped out a directory and 

all its files. 
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Fig. 2.2 Create Directory facility on File Manager Screen. 

• 

Luckily, the default settings for File Manager require to confirm the operation 

before the files and directory are all erased. Obviously user should be very careful when 

using this command. Make sure it is really needed to trash all the files in the directory 

first. Once deleted, files can be easily recovered only immediately thereafter with a 
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file-recovery program such as Norton Utilities or the UNDELETE program supplied with 

DOS 5.0. 

In the tree window select the directory to be deleted. 

Select File --> Delete or press Del. A dialog box will appear with the name of the 

directory in it. User can name a different directory if they want. 

Click on OK and the following confirmation box appear. 

To delete the directory and all its files, click on Yes to All. 

If it is clicked on Yes in the above dialog box with the confirmation messages set on, it 

will keep clicking on yes for each file before it is deleted. If it is clicked Yes to All, all files 

will be deleted with no further ado. 

It can be told to File Manager not to bug user about each deletion if user wants to, via 

the confirmation dialog box. However, be cautious when cancelling confirmation settings, 

since they are designed to prevent accidental file erasure. 

2.3 Working With Files 
Once the correct drive and directory have been selected, it can copy, move, 

delete, run, open, or print any files as per requirement. User can do all the work with files 

by selecting them in the file window and dragging file icons around or choosing commands 

from the File menu: 

As an example, try opening any directory. (Make sure the right drive first - 

probably C.). Its file folder icon opens up when the directory is open. 

The contents of the directory are shown in the right side of the window. It shows 

the complete path name of the directory in the window's title bar. Enlarge the 

window Cif it is not already enlarged) to see more files. Each file has an icon. File 

Manager chooses these icons on the basis of each file's extension. 
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Fig. 2.3 Deleting Directory Facility on File Manager Screen. 
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Here are the icon types and what each represents: 

Icon File Type 

Directory files. These will open a Directory window 
when clicked on. 

Program and batch files. These will run when 
clicked on. 

Document files that have an association. These will 
open and run the program that aerated them at the 
same time. 

System or hidden files. Unless it turn on the 
option to show system or hidden files, these will 
not be listed in the contents window. 

All other files. Double clicking on these will 
do nothing except getting an error message. 

   

2.3.1 Modifying a Directory Listing to Show Specific Information  
Normally the file pane shows all the files in the directory with as little information 

about each as possible. The file name and an icon are visible on the screen. For more 

detail information about the files, including files' names, sizes, attributes, and last 

modification date or some other combination of these, user can opt to do so. The view 
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menu has three commands to help out: 

Name lists only the name and icon of each file, use this setting to see the greatest 

number of files in the windows, windows packs in three times as many files 

this way than when all the information is displayed. This is the default 

setting. 

All File lists all the data (name, size, date and time Details  of last modification, and 

attributes). 

Partial lets user set various options from the dialog Details Box. The choices are 

self-explanatory. File attributes are Read Only, System, Hidden, and 
Archive. Once having the needed settings clicking on Of< will save the 

setup, and the File Manager will use it to display directories until it change. 

2.3.2 Sorting The Directory Listing 

Normally the directory contents are alphabetically sorted according to their names, 

with directories listed first and files following them. Using the View, menu, user can elect 

to sort on the basis of other information. For example, the files in the Zip directory sorted 
by type, meaning by file extension (the last three letters after the period in the file's name). 

sorting by type shows the file names are arranged in alphabetized within each extension, 

and extensions that start with numbers appear before letter extensions. 
Whichever choosed setting will now apply to all directories until it changes, even 

in future sessions with the File Manager. If it is selected to save the settings at exit 

(Options --> Save Settings on exit.) 

2.3.3 Showing Only Specific Files  
User can choose to see only specific files in a directory window, temporarily 

hiding the rest. This is similar to specifying wildcards for a file name when using the DOS 
DIR command. For example, at the DOS Prompt user might type the following command 

to see all the executable Program files: 
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DIR *.EXE 

This command will show all the EXECUTION FILES. 
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DIR 198?.WK3 

It will show all files with 198 as the first three of four characters and .wk3 as the extension. 

DIR ACCOUNTS.WK3 

It will show a file with this exact name. 

To limit a directory listing, follow these steps 

Choose View --> By File Type. The dialog box will appear. 

Normally all four File Type boxes are checked, meaning that all files (except hidden and 

system files) are shown. Leave an 'x' next to only the types of files user wants to see, and 

click on OK. 

2.3.4 Viewing More Than One Directory at a Time  

There are two ways to select a drive to display its directory contents. Each way 

yields a different result. The first leaves only one window open and replaces its contents 

with the new information when user selects a new drive or directory. The other opens 

additional windows for each drive. There are advantages to each. 

The first method eliminates clutter by keeping unnecessary windows from filling up 

the screen. But having more than one window open at a time lets user copy and move 

files between directories and drives with less effort. To open additional drive windows, 

either double-click on the drive icon of the choice or choose Window --> New Window. 

New Window brings up a second window identical to the first one. User can then change 

the drive or directory by the usual means. 

Open as many windows as needed. The title bar of each displays the selected 

drive, directory, and whether a file-selection filter is in use (i.e., the file type). if multiple 

windows have the same directory selected, the title bar information-will be followed by a 

number. 
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Choose window --> Tile (Shift-F4) or window --> Cascade (Shift-F5) to tile or stack the 

windows, lilt is expected to need quick access to each drive window later, adjust the 

windows to a usable size, then iconize them. The next time double-click them, they'll pop 

up in the size location in whit user left them. 

Fig. 2.5 Types of Files in File Manager Screen 
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2.3.5 Refreshing The Directory with Files 
To refresh the screen, press F5 or choose the window ---> refresh command 

24 Searching For a Specific File 
As hard disk storage capacities have skyrocketed in recent years, looking for a 

specific file when user can't remember where it was put, can be a real headache. If it 

have a lot of directories, opening each one and examining the files can take a ridiculous 

amount of time. Even in DOS, the DIR command is no help, since user has to keep 

switching directories and retyping the command. Some utility programs such as Norton's 

File Find are real time savers if DOS is using. But within Windows, the Microsoft people 

are thoughtful enough to build such a utility into the file Manager - only it's superior to 

FileFind because the files it finds are plopped into a window that can be seen on file 

screen or iconize for data access. 

Here's how to use it: 

Select File --> Search. The dialog box appears. 

Type in the name of the file looking for. use wildcards if needed. 

Fill in the Start From line. As a default, the search starts from the current 

(highlighted) directory This is like switching to a directory in DOS with the CD 

command before issuing a DIR command. 

If user wants to search down all the subordinate branches from the current 

directory to the end of the branch, click the Search All Subdirectories check box. 

if user wants to search the whole disk, check the Search All Subdirectories box 

and enter \ into the Start From line. 

Click on OK. Windows will conduct the search on the current disk(floppy or hard) 

and display its search results in a new window called Search Results. if the File 
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Manager status bar is on, it will tell how many files were found. If no files were 

found, a message to that effect will appear on the screen. To cancel a search in 

progress press Esc. 

Fig. 2.6 Multiple Directory Listing on the File Manager Screen 
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Windows helps to fill in the Search dialog box with whatever is selected in the 

active File Manager window. The selected directory will be in the Start Search From text 

box and the extension of any selected file will be in the Search For text box. The Search 

Results window is like any other window (user can tile it, iconize it, move it around, resize 

it, and so on). User can also think of it as any file pane - it can move, copy, delete, and 

rename files, and it can perform these and other actions the same way as user does 

from the drive windows. However, if exit from the File Manager, the Search Results 

window will not be saved. Therefore, if user wants to return to it later, instead of closing 

File Manager, just iconize it, and the search results will not be lost. On the next 

conducting search, the Search Results window's contents will be erased and then 

replaced with the new search results. 

2.4.1 Selecting Files in a Directory Pane  

Now let's return to the regular directory pane. Before doing work with the files in 

a directory, select one or more of them. As with other objects in Windows, select files by 

highlighting them. Here are various methods of selecting (and deselecting) files: 

2.4.2 To Select One File  

Click once on the file. The Status line (the last line in the File Manager window) 

indicates that one file is selected. 

2.4.3 To Select More Than One File  

Click on the first file to select. 

Press the Ctrl key and hold it down. 

Click on each additional file which is to be selected. 

2.4.4 To Select a Group of Consecutive Files 

Click on the first file in the series. 

Press the Shift key and hold it down. 
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Move to the bottom of the group which is to be selected and click again. All the 

files between the first and last click will be selected. 

2.4.5 To Select Several Groups of Consecutive Files 

Select the first group as described above. 

To select the second group, hold down the Ctrl key and click on the first file in the 

second group. 

Press the Shift and Ctrl keys simultaneously and click on the last file in the second 

group. Repeat the above steps reported under 2.4.5. 

2.4.6 To Select All the Files in a Directory 

Choose File --> Select Files. 

From the Select Files dialog box, choose Select with the File(s) space set 

to Y. 

2.43 To Select Particular Files  
The File --> Select File command provides a way to select specific files in a 

directory Just as in the Search dialog box, user can uses wildcards, extensions, or file 

names to filter the selections: 

Choose File > Select Files. 

Enter appropriate file information in the File(s) text box. 

Choose Select. 
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c: mytnlogy \ msmc20.bmp 

2 cArnythlogy1msmc21.bmp 
c: mythlogy rnsmc22.bmp 
c:Vnythlogy imint-23.bmp 
c: mythlogy1msmc24.bmp 
cAmythbgy \ msmc25.13mp 

cAmythlogy1msmcabmp 
cAmythlogy msmc4.bmp 

"191  h logOinismc 5. bmP 

cArnYthlogY munce.binP 
c:Nmythlogy \ msmc7 bmp 
c: mythlogy \ msmabmp 
c: mythlogy ruz.mt.9.bmp 
cAmythlogy1pron_dabmp 
c: \ mythlogy pton_up.bmia 

111 r.1miathInniArparleng. ha  

32 SEW found 

2j- 

4 

Fig. 2.7 Search Commands are displayed in Search Window 

2.4.8 To Deselect File(s)  

o To deselect all the files currently selected, either click on a single file (release the 

Shift key first) or choose File --> Select Files --> Deselect with *.* in the File(s) 

space. 
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To deselect a single file from a group of selected files, hold down the Ctrl key and 

click on the file again. 

To deselect files with a common element, choose File --> Select Files --> Deselect 

with the appropriate file information entered in the File(s) space. 

Once highlighted, a file or group of files can be operated on via the mouse or the 

commands in the File menu. 

2.5 Operations of the File Menu 

Open Opens a document file, such as letter, report, or worksheet, by running the 

program associated with it, and then opening the document itself. User can 

also open a document by double clicking it. Except for the supplied 

Windows programs, this requires setting up an association first. if the file 

is a program, this runs the program. The file must be a program file (wide 

a .BAT, .EXE, .COM, or .PIF extension). 

Move Moves file(s) to another directory or drive. 

Copy Copies file(s) to another directory or drive. 

Delete Deletes selected file(s). 

Rename Rename selected file(s). 

Run Presents a dialog box into which user can type a program 

name (with a .BAT, .EXE, .COM, or .PIF extension). This is 

like typing a program name from the DOS prompt. 

Print 
Prints text files. Use it only with ASCII files, such as those created by 

Notepad. 
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Associate Tells Windows the application for which a document was created. The 

program will then be run when the document is opened. 

Create Creates a subdirectory under the selected root or Directory 

Search Searches a drive and/or directory for files that specified by name or using 

wildcards. 

Select Files selects directory files by name or per wildcard specifications. 

2.6 Running Programs From The File Manager 

User can run programs directly from the File Manager. Do not have to return to 

the Program Manger to bring up a DOS prompt or create a program icon. This is most 

useful for running a program occasionally. Here are two ways to run Programs: 

Double- click on the program name. It should be an .EXE .COM .PIF or .BAT 

extension. 

Choose File --> Run. Type the name of the program into the dialog box. Include 

the path name if it's not part of the system's PATH command. (But always include 

the extension.) 

2.7 Printing From The File Manager 

User can print many types of files from the File Manager. Printing this way, the 

File --> Print command runs the application, loads the selected file, and executes the 

application's Print command, sending the selected file to the Window's Print Manager, 

which handles the printing. 

There are a few advantages to this approach. It makes printing very easy- Just 

drag the file(s) into the Print Manager icon or window and printing commences. But the 

file must have an associations or this technique won't work. (Even then, not all applications 

support this technique for printing.) 

Training Course on 
Basic Computer Skills V-29 

NIH, Roorkee 



Ili I IP PS] ‘1 
St./indow ffelp 

cB  g: 

salUgiA eii*  L  

a  NO 

JP El 

File Management in DOS and Windows 

fit 7'7  113  11.-s)1 LI.1011 
Dee View Qption 

Qpen Entes 
— Move.. F7 

F8 
Qatar_ 
Rename 

- 
fatal— 
Pint 

Crigate Directory.. 
Search.. 
aelect Fies 

Exit 

Ct1 leap 
n:I msoffice 

mythlogy 
nwc12 
pusgra-1 
psfonts 
sh40 

lemahnknno 
4 

Commands for waking with disks 

Ak+Enter 

D umnith 
11 0_gm.criv D yarro6.kbr 
m2m1.cnv D td. std 

mt32cnv D told vaitdp 
t32_gincnv 0 varictstdp 

trtd11 0 various2t4p 
lib2c111 D rbvstayo 
pro.ette D tdreadme.wri 
gister. frm 
pro.hlp 

 110.kbr 
nmidi.kbr 

18.kbr 
D kawk3.kbr 
D ml.kbr 
o mt32kbr 
D proteus.ka 
D sr16.kbr 
D sy22.kbr 
D u20.kbr 
D u201at1n.kbr 

Fig. 2.8 File Manager Screen for File Menu 
• 

It may also find that user has more control over the hard copy if they print using 

the source application's File menu, since some applications set print options (such as 

headers and footers landscape or portrait page orientation, etc.) before Printing. Printing 

from File Manager gives no options other than convenience. 
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To Print From The File Manager: 

Select the file to be print. 

Choose File --> Print. A dialog box appears with the file's name typed in, 

Change it if it is required, and then click on OK 

2.8 Moving Files 

2.8.1 To Move a File to a Different Directory 

Sometimes to move a file or group of files from one directory to another, this 

process is normally a real pain in DOS prompt, which requires to copy the files to the new 

directory and then erase the old ones. 

The File Manager makes this potentially tedious task a breeze. Select the files to 

be moved and then drag them as a group to the new destination. (remember that moving 

is not copying. After the operation, there is still only one copy of the files which is moved - 

they're just in a new location). The new destination can be an open window, an iconized 

window, a folder in the tree pane. a disk-drive icon in the drive window, or a group icon 

or window in the Program Manager. There is a number of choices. To move the file, try 

selecting it and dragging it to the new location. If Windows can not do it, user'll be told, 

but the chances are good that to drag a file or a directory to almost any icon or window. 

Here are the general steps for moving files around: 

Open the directory containing the file which is to be moved. 

Adjust the display so that an icon, folder or window of the destination is visible. 

Maximizing and/or tiling the windows can make this easier. 

Select the file which is to be moved. 

Drag it to the destination icon, folder, or window. The icon will disappear from the 
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original location and the mouse pointer will change to a document icon. (If it is 

moving more than one file, the icon will look like a stack of three little pages.) 

Release the mouse button. A dialog box will ask to confirm to move the files. 

Click Yes to complete the move. 

If it is tried to move files between drives without holding down the Alt key, 

Windows will assume that only copying of them is required. In that case, a plus sign will 

appear in the file icon when it's dragged beyond its window and into the new drive window. 

2.8.2 Moving Directories  
The File Manager lets user moves complete directories or directory branches. 

When it move a directory, all the files in the directory are automatically moved. 

User can select the directory to be moved either from the tree pane or from the directory 

(file) pane. Just drag the directory's folder from either pane to the new destination: 

When it move a directory or another directory, Windows adds it below the 

destination directory. 

when it move a directory from one drive into another drive's icon, it gets added 

below the current directory in the destination drive, More often than not, people 

want to move directories around on the same drive. This is extremely easy with the 

File Manager. 

To Select the directory user wants to move (in either pane) and drag it to its new 

location. As they slide the mouse over its Possible targets, a line forms around the 

target, indicating where the directory will land if the mouse button is released. 

When the mouse button is released, the directory will be added as a subdirectory 

one level below the destination directory. 
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Fig. 2.9 Print Command From The File Manager 

2.8.3 Moving Multiple Directories Simultaneously  

User can move the contents of more than one directory at a time, but unless they 

are connected by a descending branch user has to do this from a directory (file) pane, 

not from the tree pane. For example, suppose user wants directories One, Two, and Three 
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to be subdirectories under a directory called Four. It can be done only by dragging one 

directory at a time. But it's faster to do it in one fell swoop. Select directories One, Two 

and Three in the directory Pane. Drag them as a group to Four in the tree pane. 

directories One, Two, and Three were added under Four as subdirectories. Unless it 

changes the confirmation settings, File Manager asks to confirm the actions before 

moving the directories. 

2.8.4 Entering the Destination from the Keyboard  

Sometimes just typing in the name of the destination is easier than dragging the 

files and directory icons around, especially if it is fast at the keyboard. With this technique, 

the destination does not have to be visible. Just select the source files or directories and 

choose File --> Move. Type the name of the destination drive and directory into the dialog 

box that appears. If multiple files are selected, the From box lists them all, end to end, 

with a space separating the names. When moving a directory, it will be added below the 

destination directory. 

2.8.5 Moving Files And Directories to Another Disk Drive  

Moving files and directories to another disk drive can be done in several ways: 

Open windows for the source and destination drives, then drag the directories or 

files from one to the other. 

Select the source files or directory(s), choose File --> Move and type in the 

destination drive and directory. 

Select the source files or directory(s) and drag them into the destination drive icon 

as described below. 

It can drag selected files or directories to another drive using the drive icons at 

the top of the drive window. The File Manager will use the current directory of the target 

drive as the final destination. To do this: 
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Select the files or directories. 

Hold down the Alt key, since it is moving to another drive. 

Drag them into the destination drive icon. If user is moving the directories or files 

to a floppy drive, make sure it has a formatted disk in the drive, or it will give an 

error message. 

A dialog box will ask to move the items. Click Yes. (If the dialog box asks about 

copying (not moving), just forgot to hold down the Alt key. Click on No and try 

again.) 

After moving a directory, the File Manager asks to user to delete the original. 

When moving files, user is not asked this (they are just deleted). 

When the files are moving about, Particularly to a floppy, there may not be 

enough room on the floppy for all the source files. File Manager shows how many bytes 

user has got selected in the status bar of its window, when clicked on the drive window 

for the floppy, the status bar tells how much room is left on it. So, if open one window 

for the floppy and one for the hard disk directory from which copying from, It can switch 

back and forth between the two to make sure user is not going to run out of space 

during the moving process. 

2.8.6 Copying Files  
Copying differs from moving in that it duplicates the items working with. Copying 

is often used for transferring files between computers, for installing software into the 

computer, or as a safety backup procedure. Though there are programs specifically 

designed to back up the entire hard disk in an efficient manner, the Copy command is 

useful enough for making backups of individual files. 

2.8.7 Making the Copy  
Just as with moving, It can stipulate the source and destinations of items by 
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selecting the Copy command. If the source items are selected using the mouse, they'll 

be inserted into the From line. Then just type in the To information - Copy files and 

directories virtually the same way it is moved them with a couple of exceptions: 

Arrange the screen so that source and destination windows, icons, files, or drives 

are visible. 

Select the item(s) to be copied. 

Press the Ctrl key. 

Drag the items to their destination drive, icon, window, or directory, and release. 

Answer dialog boxes appropriately. Check the dialog box to make sure it says 

Copy, not Move. Make sure to see the correct destinations, too. If not, type in the 

changes or try again. 

2.8.8 Copying a File to the Clipboard  
User can copy a file from File Manager directly to the Clipboard so that it 

can be linked or embedded in another document. This procedure uses the Copy 

command. Here's how its done: 

To Select the file to be copied. 

Choose File --> Copy or press F8. 

In the Copy dialog box, click on Copy to Clipboard. 

o Click on OK. 

Once the above steps are followed, it can open the Clipboard Viewer to see the 

document (or see a note saying it can't be displayed). It can get Clipboard Viewer in the 
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Main group of the Program Manager (unless it is moved ). From the Edit menu of an 

appropriate application (one that can accept the file just put on the Clipboard) it can then 

paste the file's contents into a document. 

After any form of copying, the originals are left intact, so user does not has to 

worry about losing anything if makes a mistake. The only thing to worry about is copying 

a file on top of a file with the same name. File Manager will ask if user wants to overwrite 

the old file with the new one, unless it has turned off this confirmation message. 

2.8.9 Changing The Confirmation Settings  

The File Manager has some safeguards against accidental erasure of files and 

directories. Usually it's a good idea to leave these settings as they are. Once the user has 

more experience with the ways of the File Manager, though, they might want to change 

them so they don't nag every time to overwrite an old file or delete a directory that has 

a bunch of subdirectories under it that to be deleted: 

Choose Options --> Confirmation. 

The dialog box shown below appears. The Confirm On settings have the following 

meanings 

File Delete asks for okay to delete files. 

Directory Delete asks for okay to delete directories. File Replace asks for okay to overwrite 

an existing file. Mouse Action asks for okay any time to attempt to copy, delete, or move 

files or directories with the mouse. Disk Commands asks for okay to format or copy a disk. 

2.8.10 Deleting Files  
Deleting files means erasing them. It's difficult to recover them after they're deleted. 

Delete a file by following these steps: 

Select the file(s). 
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Press Del or choose File --> Delete. A dialog box appears. 

Check the information in the box. If it's correct, click OK. If not, Cancel it or change 

the information by typing in another file name. It can add a drive letter and path, 

just as with the DEL command in DOS. 

2.8.11 Renaming Files And Directories  

Renaming files is done in a manner similar to deleting. It simply changes the name 

of the file or directory selected. This command can also be used with directories: 

Select the item to be renamed. 

Choose File --> Rename. A dialog box appears. 

Type in the new name and click on Rename. 

2.8.12 Changing File Attributes  

Changing file attributes is easier with Windows than with DOS, by far. Simply 

select the files, open a dialog box and set the check boxes appropriately. The most 

common setting change for files is to set them to Read Only. Once this is set, nobody can 

accidentally erase or overwrite them. Here's how to set the various attributes: 

Select the file(s) whose attributes are to alter. 

Choose File --> Properties. 

The dialog box appears: Check the boxes appropriately. Here are the meanings 

of the choices: 

Read Only won't allow user to makes changes to the file. 

Archive indicates the file has been modified since the last backup. This is used by 
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backup programs such as the DOS BACKUP command. 

Hidden will hide the file from directory listings in DOS and directory windows in File 

Manager (unless choose View --> By File Type --> Show Hidden). 

System tells Windows and DOS that this is an operating system file. It will normally 

be hidden (unless choose View --> By File Type > Show System). 

2.8.13 Working With Disks  
The File Manager has a few features that apply specifically to managing the disks, 

particularly floppy disks. These commands make the process of formatting disks and 

copying disks a bit simpler. There's also a command for changing the volume label of a 

disk, the optional name that each floppy or hard disk can be assigned, typically for archival 

purposes. 

2.8.14 Formatting Disks And Making System Disks  
What with the myriad disk capacities and sizes around these days, formatting a 

floppy disk can turn out to be quite an exercise in futility. The DOS manual is usually not 

much help either. There are enough options to the format command to choke a rhino. 

Here's how to format a disk now: 

Put the disk to be formatted in the floppy drive. 

o Choose Disk --> Format Disk. 

The dialog box below appears. Use the drop-down lists to set the drive and 

disk capacity of the floppy. 

In the Options section of the box. 

a label. Then check on Make 

appropriate. Select Make System 

to be able to boot up a computer  

It may give the disk a name by typing in 

System Disk and/or quick Format if 

Disk if user wants the disk formatting 

from the A drive. The necessary hidden 
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system files and COMMAND.COM  will be copied to it during the formatting 

process. Quick Format deletes the file allocation table and root directory of 

the disk, but the disk is not scanned for bad sector areas. Use this option 

only for disks that have been formatted before. 

Click OK. 

If user want to go ahead and format the disk, click Yes. User will be 

informed of the progress. 

2.8.15 Copying Disks  
User can make copies of disks by two ways. If the disks have the same 

capacities, Copy Disk command can be used. Just select all the files with wildcards (*.*) 

in the From section of the Copy dialog box and perform the copy. If the two diskettes have 

the same capacities, use the Copy Diskette command (it's faster). However, be aware that 

this command, like the DOS DISKCOPY command, erases everything on the destination 

disk before creating an exact copy of the source disk. 

Put the source disk in one drive and the destination disk in the other. If it 

has only one drive, insert the source disk in it. 

o Click on the drive icon for the source disk. 

Choose Disk --> Copy Diskette. 

If it has two drives, it will choose the destination drive from the dialog box. 

Follow the instructions on the screen. If it has only one drive, it will have 

to swap the disks a few times. 

2.8.16 Changing a Disk's Label  
All floppy and hard disks can have a volume label. This is not the paper label on 
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the outside, but a name encoded into the directory on the disk. It shows up when type 

DIR at the DOS prompt and on the top line of the drive window when switch to that drive 

in the File Manager. The label really serves no functional Purpose other than to identify 

the disk for archiving purposes. When format a disk in DOS or with the File Manager, it 

is given the chance to assign a volume label. File Manager lets change a disk's label. 

Here's how: 

Insert the disk in the drive. 

Choose Disk --> Label Disk. 

Type the label into the dialog box (up to 11 characters) and click on OK. 
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Fig. 2.10 Menu of working with Disks in File Manager 
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