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FILE EDITORS

In the present lecture, two commonly used editors will be discussed. The first is the Norton Editor and
the second is the DOS Editor which comes along with DOS.

1.0 NORTON EDITOR

The Norton Editor has been published by the Symantec Corporation while the copyright of the version
2.0, 1990 lies with S. Reifel & Co. It is a tool used for creating and modifying text files such as letters, memos
and computer programs and computer generated data. While a number of word processing softwares are
available, the most important application of the NE lies in writing computer programs and analysing the results
thereof.

A number of operationslike File operations, Block operations, Textlayout op erations, Searchoperations,
Print opcrations €tc. arc helpful in writing and editing a document. These operations along with the various sub-
options &re described in the following.

7ile Operations

. number of file operations are possible in the Norton Editor. These include opening a file, saving a
file, ¢ anging name of file, merging two files, opening two files at a time, reaching at the top of a file, entering
DOS shell without exiting NE etc. Pressing the Alf key and F key together activates the File Operations. Major
options under these operations are explained below:

Creating a File
Alt-F N creates an empty untitled file. N represents a New file. After the work is completed, the name
is to be given to the file.

Opening a File
Alt-F O loads an existing file. O represents Opening a file before exiting NE.

Saving a File
Alt-F S saves the file being edited. S represents Saving a file. It is advantageous to keep saving a file
while working so as 10 avoid any work 10ss due to power failure or otherwise.

Renaming a File
Alt-F A saves the file being edited with a new name. 4 represents Save As.

Merging Files
Alt-F M merges another file into the one being edited at the location of the cursor. M stands for
Merging.

Opening Second File
F2 function key opens a new window on the screen to edit a second file. If two windows are already

open, this key moves the cursor from one window to other activating that particular window. This option is
highly useful for analysing the results and testing the computer programs.

Closing Second File
Alt-F C closes the second window. C represents Closing the second window.

Exiting a File
Alt-F X exits the editor and returns to DOS. X stands for eXiting.
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Entering DOS Shell
Alt-F D enters a DOS shell for executing some DOS commands. After executing the DOS commands,
it returns to the existing file in the NE.

1.2 BLOCK OPERATIONS

In editing or creating a text file or a computer program, it is often required to type a part of the file
or program at some other place. Block Operations perform this important task thereby avoiding the need of
- retyping. In addition, they also help in printing a certain part of a long text or in copying certain part in a new
file. Block operations are activated by pressing the ALT and B keys simultaneously. Various important Block
operation options are described below:

Setting a Block

Alt-B § sets a block marker at the cursor. § stands for Setting the marker. For selecting a block, two
markers are required, one at the beginning and the other at the end of the selected block. Markers may also be
set by dragging the mouse with the left button pressed.

Copying a Block
Alt-B C copies a block of text to the cursor. After setting a block, the cursor is moved to a place where
the block is required to be copied and then the command is pressed. C stands for Copying.

Moving a Block
Alt-B M moves a block of text to the cursor. In copying, the block at the original place remains as such
while in moving. the block shifts from original to the new place. M stands for Moving.

Deleting a Block
Alt-B D deletes a block of text. D represents Delete.

Writing Block to a File
Alt-B O writes the block of text into a file. O stands for Output to file.

Finding a Block
Alt-B F moves the curser to the next block marker. F represents Find.

Removing Block Settings
Alt-B R removes the block markers. R stands for Remove.

1.3 TEXT LAYOUT OPERATIONS

The usefulness of these operations is mostly in preparing a text document rather than in writing a
computer program. These operations are activated by pressmg the ALT and T keys together. Some major options
in these operations are described below:

Document Formatting

Alt-T P formats a paragraph of the document in accordance with the settings. P stands for Paragraph.
Alt-T D formats all paragraphs of the document. D represents Document. A%-T C centers a line in accordance
with the set left margin and line length.

Setting up

Alt-T S sets the left margin and line length used to format paragraphs and centering lines. Settings are
also used for word wrap.
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Word wrap
Alt-T W toggles word wrap On and Off. Word wrap automatically places a new line into the file after
typing past the set line length. "WW=0n" is displayed on the status line when enabled.

Inserting or Removing Page Breaks

Alt-T I inserts page breaks for printing. Text following the page break is printed at the top of the next
page. The setup dialog box under the Print menu sets the page length. Al-T B removes page break characters
from the file.

Tabs
Alt-T T replaces spaces at the beginning of all lines in the file with tabs. Al-T E replaces all tabs in
a file with spaces.

Auto Indent
Alt-T A toggles automatic indent On and Off. Pressing Enter with this enabled creates a new line and
indents the cursor to the same level as the line above. "Auto" is shown on the status line when enabled.

1.4 SEARCH OPERATIONS

Especially in writing or editing a computer program, Search Operations are of immense use. These
operations are activated by pressing together the Alf and § keys. Various important options under these operations
are discussed below:

Finding a String
Ctrl-F searches for a string. Al-C continues the previous find in the forward direction while Ctri-C
continues the search in the reverse direction.

Finding & Replacing
Ctrl-R searches for a string and optionally replaces those found.

Searching Line Number
Alt-S L moves the cursor to the given line number of a file. Dialog box prompts for line number.

Matching Brackets
Ctrl-] moves the cursor to the opening or closing bracket that mates with the (<{[ ]}>) under the cursor.

Search for a Text in Block
Alt-S B searches forward for other copies of the text inside a marked block. Al-§ M moves the cursor
to the next block marker.

Difference Comparison
Alt-S D compares the text between two files. Search begins at the location of each cursor in the two
files. This option is used when both the windows are On.

1.5 PRINT OPERATIONS

Print operations are useful il printing a document. It is activated with the A/t and P keys pressed
together. Various options are as under:

Printing the Text
Alt-P P prints all the text in a file.
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Printing a Block
Alt-P B prints the text in a marked block only. It is useful when only a part of a long document or
program is to be printed.

Setting up Printing
Alt-P § sets the left margin and page length for printing.

1.6 VIEW OPERATIONS

These operations display variety of information. These are activated by Alt and V keys and works with
the following options:

Information Display

Alt-V I displays a variety of data including name of file being edited; length of file in characters, words
and lines; current directory; todays’ date and time; amount of unused memory and disk; and ASCII code of
character under cursor.

Outline Display

Alt-V O displays the file in an outline format. Only lines that begin with a number or letter in the left
most column are shown. The arrow keys are used to quickly scroll to the desired line of the file. This command
is most commonly used by C and Pascal programmers.

Information about NE
Alt-V A displays information about the editor.

1.7 CONFIGURATION OPERATIONS

These operations sets or alters the configuration of the Norton Editor. Various configurations are
possible and the user can set a configuration in accordance with the requirements. Various options under these
operations are as follows:

Setting Display Configuration
Alt-O D sets display configuration including colour, number of screen lines, tab width. enablesthe scroll
bar, zoom display of dialog boxes, and blinking of matching bracket when cursor right of )}] character.

Setting Mouse
Alt-0 M sets mouse configuration including selecting active mouse button, scroll speed etc.

Setting Editor
Alt-0 E sets editor configuration including naming of backup files and operation of Ins and Tab kevs.

Saving Configuration
Alt-0 § saves current configuration settings.

1.8. GETTING HELP

Dialog boxes presenting help information are controlled by software buttons. Each button is located
near the bottom of the dialog box and is labeled with a word describing its function. A button is pushed by
either clicking on it using a mouse, or by pressing a key. The key for most buttons is its first letter. Cancel
buttons, which remove dialog boxes, are always pushed with the Esc key.

Every dialog box has a default button that can be pushed with the Enter key. Some dialog boxes have

several fields where information can be set. The Tab and Shift Tab keys are used to move the cursor to the field
to modify. Then the space & arrows are used to make the changes.

NATIONAL INSTITUTE OF HYDROLOGY, ROORKEE 4




File Editors

On the top line of the screen is a menu bar. To select an item in a menu, hold the Alt key down while
pressing the first letter of the menu name. Then press the highlighted letter of the desired menu item.

2.0 MS-DOS EDITOR

MS-DOS Editor is a useful tool for customizing the system. Files created by MS-DOS Editor are
unformatted text files. It is a text editor which can be used to create, edit, and print memos, letters, and special
files that customize MS-DOS. While working with MS-DOS Editor, both the keyboard and a mouse can be used.

Using MS-DOS Editor, the following operations can be performed:

Choose commands from menus and specify information and preferences in dialog boxes.
Select text and move, copy, or delete it.

Find and replace the specified text.

Use Help to find information about MS-DOS Editor procedures and commands.

O 0O OO0

2.1 Getting Started with MS-DOS Editor
There are two ways 1o start MS-DOS Editor:

At the command prompt
In MS-DOS Shell.

a O

To start MS-DOS Editor at the command prompt:
Tyvpe edit at the command prompt. To open an existing text file include its path and filename, as in the
following example:

edit d: \work\program. txt
MS-DOS Editor starts with the PROGRAM.TXT file loaded.
To start MS-DOS Editor from MS-DOS Shell:

(a) Using Mouse
o In the Main group. double-click Editor. The File to Edit dialog box appears.
o To create a new file, click OK.

To adit an existing file. type its path and filename in the File to Edit box, and then click the OK button,

(b) Using Keyboard
0 Press TAB to move to the Main group.

Use the Up ARROW or DOWN ARROW key to move the selection cursor to Editor, and then

press ENTER. The File to Edit dialog box appears.

o To create a new file, choose the OK button.

O

To =dit an existing file, type its path and filename in the File to Edit box, and then choose the OK

button.
While tying only the word edit at the command prompt, or choose the OK button in the File to Edit
box without specifying a filename in MS-DOS Shell, the following screen appears:

To get information about MS-DOS Editor when this screen appears, press ENTER or click the phrase,

"Press Enter to see the Survival Guide." An introduction to MS-DOS Editor and its Help system is then
displayed.
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To start working with MS-DOS Editor, press ESC or click the phrase, "Press ESC to clear this dialog
box." An empty window appears. Work on text files by typing or editing text in the window.

If a filename is specified while starting the MS-DOS Editor, then that specified file appears instead of
the dialog box. To get information about MS-DOS Editor after a file has been loaded, press F1.

Working with Menus
To perform tasks in MS-DOS Editor, choose commands from menus on the menu bar. The menu bar
is displayed at the top of the MS-DOS Editor window.

o To select a menu

Using Mouse  : Click the name of the specified menu.
Using Keybhoard:
- Press ALT. The first menu name, File, is selected.
- Press the LEFT/RIGHT ARROW key to select the required menu and press ENTER.
Or type the first letter of the menu name.

© To choose a command:
Using Mouse  : Click the command.
Using Keyboard : Press the UP/DOWN ARROW key to select the required command, and
press ENTER. Or press the highlighted letter in the command name.

There are some commands (e.g. cut, copy, paste etc) which do not have a highlighted letter. Before
using these commands some necessary action is to be performed on which the required command is to be
applied. For example, to use Cut command, it is necessary to select some text.

There are some commands which can be chosen by using shortcut keys. If a command has a shortcut
key, it is displayed next to the command name on the menu.

© To cancel a menu without choosing a command:
Using Mouse  : Click anywhere outside the selected menu.
Using Keyboard : Press ESC.
o

© Working with Dialog Boxes

While choosing some commands, a dialog box appears. Type additional information or select options
in a dialog box. For example, to choose the Open command from the File menu, the Open dialog box appears.
Most dialog boxes have areas where one can type information or select options. To move from one area to
another press TAB. (To move in reverse order, press SHIFT+TAB.) While using a mouse, click the required area
needed to work in.

Most dialog boxes contain one or more of the following items:

- A text box in which a text can be typed. If the selected box already contains text, clear it by
typing characters or by pressing the SPACEBAR.

- A group of options with a dot next to the currently selected option. Select an option by
clicking between the parentheses next to the required option, or moving the dot by using the
arrow kevs.

- Check boxes (select or clear). To select a check box, click it; or use TAB using to move the
cursor to the check box, and then press the SPACEBAR. To clear a check box, click it again;
or press the SPACEBAR again.

- A list of files, directories, and drives.

- Command buttons, such as OK, Cancel, and Help (located along the bottom of the dialog box.
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The OK button carries out the command and closes the dialog box. When the angle brackets around the
OK button are highlighted, press ENTER to carry out the command, or click the OK button.

The Cancel button cancels the command and closes the dialog box. There are three ways to cancel a
command: by using TAB to select the Cancel button and then pressing ENTER: by pressing ESC; or by clicking
the Cancel button.

The Help button displays information about the command. There are three ways to get Help: by using
TAB to select the Help Button and then pressing ENTER; by pressing F1; or by clicking the Help button.

o To select an item from a list in a dialog box:
Using Mouse : Click the required item. If the required item is not visible, click the scroll arrows until
it comes into view. Alternatively drag the scroll box in the scroll bar, or click the
shaded areas of the scroll bar.

Using Keyboard : Press TAB to move to the list. Use the arrow keys to move the selection
cursor to the required item. The HOME, END, PAGE UP, and PAGE
DOWN keys can also be used to move the selection cursor.

22 Using Help

There are several types of Help available in MS-DOS Editor. The following sections describe how to
use the different kinds of Help.

Status Bar

One type of help, which is always available at the bottom of status bar that displays information about
commands or keys that can be used. When one use a command, the status bar displays a short description of it.
For more information about the command, press F1.

The status bar changes while selecting a menu, choosing a command. or opening a dialog box. It also
displays information about the functions of various keys. Use this Help for a quick reminder about the purpose
of a command or for a quick reference to the keyboard.

Command, Menu. and Dialog Box Help
Obtain Help on how to use a specific command, menu, or dialog box by selecting the item and pressing
Fl. Hzlp can be cancelled by pressing ENTER or ESC.

In a dialog box, Help can also be obtained by clicking the Help button. Use this Help for knowing how
to use a specific command, menu, or dialog box.

Survival Guide

MS-DOS Editor also has Help for getting started with MS-DOS Editor and Help for using the keyboard
to navigate through text and Help. This Help is called the Survival Guide. It looks different from the other types
of Help in MS-DOS Editor. The Survival Guide contains information about editing keys, cursor movement,
dialog box, selecting text, opening and saving files, and other basics.

Use this Help while learning how to use MS-DOS Editor or when Help is needed during navigating
through text.

The Survival Guide can be used by doing one of the following:
From the Help menu, choose Getting Started or Keyboard.

When in the MS-DOS Editor window, press F1.
Immediately after starting MS-DOS Editor (and without specifying a file), press ENTER.

O 0 O
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When the Help window appears, one can choose to view any of the related topics enclosed in the
highlighted angle brackets. To view a related topic. move the cursor to it and press ENTER, or double-click the

topic.

The following keys can be used to move the cursor from one topic to the next in the Survival Guide:

TAB Moves the cursor to the next Help topic.

SHIFT+TAB Moves the cursor to the previous Help topic.

A character Moves the cursor to the next Help topic beginning with that character.
SHIFT+a character Moves the cursor to the previous Help topic beginning with that character
ALT+F1 Displays the Help window for a previously viewed help topic.

CTRL+F1 Displays the next Help topic in the Help file.

SHIFT+CTRL+F1 Displays the previous Help topic in the Help file.

Specifying the Help Path

MS-DOS Editor uses a file named EDIT.HLP to display Help messages. MS-DOS looks for this file
in the current directory and any directories specified by the path command. If the EDIT.HLP file is not found,
MS-DOS Editor cannot display Help.

One can specify the location of the EDIT.HLP file by using the Help Path command on the Options
menu.

To specify the Help path
o From the option menu. choose Help Path. The Help Path dialog box appears.
o Type the path of the directory that contains EDIT.HLP.
o Choose the OK button.

2.3 Quitting MS-DOS Editor

One can quit MS-DOS Editor and save the working file. To quit MS-DOS Editor from the File menu,
choose Exit.

2.4 Creating a Text File
Create a text file by typing text in the MS-DOS Editor window. Reaching the end of a line, press

ENTER to move the cursor to the next line. A line of text can be up to 256 characters long. The following is
a list of keys you can use with MS-DOS Editor:

BACKSPACE or CTRL+H Dczletes the character to the left of the cursor.

DEL or CTRL+G Deletes the character at the cursor.

CTRL+T Dzletes the word at the cursor (the cursor must be
under the first letter).

INS or CTRL+V Changes from insert to replace mode. The insert mode
is the default. Press INS to replace characters instead of
inserting them. Press INS again to resume inserting.

Moving the Cursor :
Both a mouse or the kevboard can be used to move the cursor. Scroll through the text to see parts of

a file that are not visible.
Using Mouse  : Click the area at the required location of the cursor.

Using Keyboard: Press the arrow keys.
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Following keys can also be used to move the cursor through text:

Arrow keys Move the cursor one character or one line
CTRL+LEFT ARROW Moves the cursor one word to the left
CTRL+RIGHT ARROW Moves the cursor one word to the right
HOME Moves the cursor to the beginning of the line
END Moves the cursor to the end of the line

1 CTRL+ENTER Moves the cursor to the beginning of the next line
CTRL+O+E Moves the cursor to the top of the window
CTRL+O+X Moves the cursor to the bottom of the window

While working with a file that is longer or wider than the MS-DOS Editor window, scroll through text
to bring it into view.

To scroll through text:

Using Mouse  : Click the scroll arrows, drag the scroll box in the scroll bar. Or click the
shaded areas of the scroll bar.
Using Keyboard : Use the following keys to scroll through text:
CTRL+UP ARROW or CTRL+W Scrolls up one line
CTRL+DOWN ARROW or CTRL+Z Scrolls down one line
PAGE UP Scrolls up one screen
PAGE DOWN Scrolls down one screen
CTRL+HOME or CTRL+Q+R Moves the cursor to the beginning of a file
CTRL+END or CTRL+Q+C Moves the cursor to the end of a file
CTRL+PAGE UP Scrolls Ieft one screen
CTRL+PAGE DOWN Scrolls right one screen

Scrolling can also bz done by holding down an arrow key.

Selecting Text

Most of the editing operations are carried out by selecting a block of text. In a single line, you can
select any amount of text, from a single characterto the entire line. One can also select several lines or the entire
file at once.

Using Mouse Point to the first character to selected. Drag the cursor to the last character to be
selzcted. Release the mouse button. To cancel a selection, click anywhere in the
window.

Using Keyboard : Use the arrow kevs or other cursor-movement keys to move the cursor to the first

characterto be selected. Press and hold down SHIFT, and use the arrow keys to move
th= cursor to the last character to be selected. Release the keys. To cancel a selection,
pr=ss any cursor movement key.

Once text is selected. it can be deleted by pressing DEL, or edit it by using the commands on the Edit
menu.

2.5 Editing Text
The Edit and Search menus in MS-DOS Editor list the commands used for editing the text. Using the

commands on the Edit menw. one can move or copy a block of text from one part of a file to another. This can
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be done by transferring text from the working file to a temporary storage area called a buffer. Using the Search
menu, one can search for a set of characters in a file. The characters found in a search can be replaced with a
different set of characters.

Moving Text

One can move a block of text by using the Cut and Paste commands. This procedure is useful to

rearrange the order of text in a file:

o Select the block of text to be moved.

o From the Edit menu, choose Cut, or press SHIFT+DEL. The block of text is deleted from the
file and placed in the buffer. One can move all the text from the current line to the buffer by
pressing CTRL+Y. To select text from the cursor location to the end of the current line and
move it to the buffer by first press CTRL+Q, and then press Y.

o Move the cursor to the location in the file where the text to appear.

o From the Edit menu, choose Paste, or press SHIFT+INS.

The text in the buffer is inserted in the file at the cursor location.

After choosing the Paste command, the text is not removed from the buffer; it remains there until

moving or copying another block of text to the buffer. The text can be inserted from the buffer into a file as

many times as required by repeating the Paste command.

Copying Text
Use the Copy and Paste commands to copy and reposition a block of text.

o Select the block of text to be copied.

From the Edit menu, choose Copy, or press CTRL+INS. The block of text is copied to the
buffer. It is not removed from its original location.

)

o Move the cursor to the location in the file where the block of text it to appear.

o From the Edit menu. choose Paste option, or press SHIFT+INS. A copy of the text in the
buffer is inserted into the file at the cursor location. The text remains in the buffer until one
moves or copy another block of text to it. The text can be inserted into a file as many times
as required by repeating the Paste command.

Clearing Text:

The text can be cleared from the MS-DOS Editor window without copying the text to the buffer.
Choosing the Clear command or pressing DEL has no effect on text in the buffer.

o Select the text required to be clear.

o From the Edit menu, choose Clear or press DEL.

Finding Text

- To find text in a file, use the Find command on the Search menu. The text can be a word, a phrase,
or any combination of characters and spaces. When MS-DOS Editor searches for text. it starts at the current
cursor position and selects the first occurrence of the text:

o From the Search menu. choose Find option. The Fmd dialog box appears. If text is selected
before choosing the Find command, the selected text appearsin the Find What box. Otherwise,
the word at the current cursor location appears in this box. If some different text is to be
searched, type the text to be searched, in the Find What box.
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To match the capitalization exactly, select the Match Uppercase/Lowercaseoption. Otherwise,
MS-DOS Editor finds. for example, both Brown and brown.

To find only separate occurrences of the specified text, then the Whole Word option is to be
selected. Otherwise, MS-DOS Editor finds, for example, main in remainder.

Choose the OK button to start the search. MS-DOS Editor begins searching at the cursor
position. The first occurrence of the text is selected. If no occurrences of the text are found,
the Match Not Found dialog box appears.

To search for the next occurrence of the specified text, choose the Repeat Last Find command
from the Search menu, or press F3.

The Find command continues to search through the file each time one choose the Repeat Last Find
command. When it reaches the end of the file, it returns to the beginning and continues searching until it reaches

its starting point.

Replacing Text

Use the Change command to find text and replace it with new text. The Change command begins at
the cursor location and continues to the end of the file. When it reaches the end of the file, it returns to the
beginning and continues searching and replacing until it reaches its starting point.

O 0o 0O

o O

o]

Position the cursor where replacing of the text is to be started.

From the Search menu. choose Change. The Change dialog box appears.

In the Find What box. type the text to be replaced. In the Change To box,
type the text one want to replace it with.

To match the capitalization exactly, select the Match Upper/Lowercase option.
To replace only separate occurrences of the specil‘ied text, select the Whole
Word option.

Choose the Find and Verify/ Change All button to start the command. If one
choose the Find and Verify button, each occurrence of the original text is
selected, and the Change dialog box appears. The dialog box prompts to
make the change, skip the occurrence, cancel the command, or get Help. If
the Change All button is chosen, MS-DOS Editor replaces all occurrences

of the specified text.

Choose the OK button (or press ESC) when the Change Complete dialog box appears.

2.6 Managing Files

Use the commands on the File menu to open an existing file. work on a new file. save a file, or print

a file.

Creating a File

Create a file by using the New command on the File menu.

C

e]

From the File menu. choose New option. If one have an open file that has unsaved changes,
MS-DOS Editor displayvs a dialog box prompting to save the changes. Choose the Yes button
to save the recent changes; choose the No button to close the file without saving recent
changes. MS-DOS Editor closes the current file and displays an empty window labeled
"Untitled." Text can be typed in this window.

To save the new file, choose the Save or Save As command from the File menu. Then specify
the drive and directory where the file is to be stored, and give the file a name.
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Opening a File
Several types of files can be opened by using the Open command on the File menu:

- Files created previously by using MS-DOS Editor.
- Other unformatted text files (e.g. AUTOEXEC.BAT and CONFIG.SYS)

- Formatted text files created by using another text editor. Special characters may lose
their formatting functions if one open them with MS-DOS Editor.

From the File menu, choose Open. The Open dialog box appears.

Type the name of the file to be opened, or select it from the file list. If the specified file is not
on the current drive and directory, type the path as part of the filename. To view a list of the
files on a different drive/directory, move to the Dirs/Drives list, select the required drive and/or
directory. and double-click it or press ENTER key. A list of files in the current drive and
directory appears in the Files box.

3 When the name of the file required to be open is displaved in the File Name box, choose the
OK button.

o O

If a file with unsaved changes is open, MS-DOS Editor displays a dialog box prompting to save
previous changes before opening a new file. Choose the Yes button to save changes; or choose the No button
to unsave the changes. If one decide not to open the new file, choose the Cancel button.

Saving a File

After creating a file or making changes to an existing file, save it by using the Save or Save As
command on the File menu. It is a good idea to save the recent work often in case there is a power loss or
equipment failure.

CAUTION : Some files might include special formatting characters. Saving such a file while using MS-DOS
Editor. the special characters lose their formatting function.

o To save a new file:

- From the File menu, choose Save. The Save dialog box appears.

- In the File Name Box, type a name for the file. To save the file on a different drive or
directory. select the drive/directory in the Dirs/Drives box, or include a path while typing the
filename

- Choose the OK button.

o To save an existing file:
From the File menu. choose Save.

o To save an existing file under a new name:

- From the File menu, choose Save As. The Save As dialog box appears.

- In the File Name Box, type a name for the file. To save the file on a different drive or
directory. select the drive/directory in the Dirs/Drives box, or include a path while typing the
filename. If ones attempt to save a file in a directory that contains a file with the same name,
MS-DOS Editor displays a dialog box asking for the replacement of the existing file. Choose
Yes button to replace the existing file: choose the No button to save the file with a different
name.

- Choose the OK button.

TIP : Use the Save As command to save a modified version of a file without losing the original version. For

example. if one has a file named MEMO.TXT, keep the original file as it is and save a modified version as
MEMO _2.TXT.
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Printing a File
Use the Print command on the File menu to print part or all of an open file. This command works only
if a printer is already connected to or redirected through LPT1 (parallel) printer port.

o Be sure the file to be printed is open. For printing a portion of a file, select that text portion.
0 From the File menu, choose Print. The Print dialog box appears.
o} Ta print only the selected text, choose the Selected Text Only option; otherwise, select the

Complete Document option.
o Choose the OK button.

Printing a Help Topic
Use the Print command on the File menu to print Help information.

o From the Help menu, choose Getting Started or Keyboard.

o Choose the required Help topic to be printed.

o} Be sure the cursor is in the Help window. To print part Help topic. select the text to be
printed.

o} From the File menu, choose Print. To print only the selected text, choose the Selected Text
Only option; otherwise, select the Current Window option.

o Choose the OK button.

2.7 Customizing MS-DOS Editor
Use the commands on the Options menu to set the way, the MS-DOS Editor window appears.

Controlling the Screen Display
One can use the Display command on the Options menu to change the colors in the MS-DOS Editor
window, displav or hide scroll bars, and set tab stops.

To change the screen display:

o From the Options menu. choose Display. The Display dialog box appears.

e To change the screen colors, select a foreground colour and a background colour. The screen
colors depend on the type of monitor. A sample of the selected screen colors appears 1o the
left of the list boxes. The scroll bars to appear in the MS-DOS Editor window, select the
Scroll Bars option. If this option is not selected, the scroll bars are hidden and one can see
more of the window whilz working. With the scroll bars hidden, one can still scroll through
text by using the kevboard To set the tab stops, set the number of spaces between tab stops.
The default is 8.

o Choose the OK button.

The screen display can also be changed by specifying one or more switches when one type edit at the

command prompt.
* ok k

NATIONAL INSTITUTE OF HYDROLOGY, ROORKEE 13







