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OPERATING SYSTEM AND FILE EDITORS

1.0 MS-DOS OPERATING SYSTEM

A computer system is a combination of a number of individual components, namely
hardware, operating system, application programs and the user. Every component has its own
set of duties to handle. Operating system being the component which is in direct interaction
with the hardware, is responsible for allocating the hardware to the application programs.

An operating system (O/S) is an integrated set of specialized programs that is used
to manage resources and overall operations of a computer system without user-intervention.
It acts as an interface between the computer hardware and computer user. The purpose of
the operating system is to provide an environment in which the user can execute programs.

1.2 FEATURES OF AN OPERATING SYSTEM
1.2.1 Operating System As A Resource Allocator

A computer system has a number of resources, namely peripherals, file storage space,
memory space and CPU time. There has to be some component in the system which manages
these resources and allocates them to different users and programs depending upon the
requirements. Operating system is the one which does the proper scheduling of these
resources and manages them a such a manner that resources are effectively utilised.
Therefore an operating system is also referred to as a resource allocator.

1.2.2 Operating System As A Control Program

An operating system can also be viewed as a control program since it controls the
execution of the user programs in such a manner that any errors and improper use of the
hardware can be minimized.

1.2.3 Single-user/multi-user Operating Systems

All the application program consist of two parts - input/output and processing. The
1/0 devices perform input/output while CPU is busy in the processing. While a user is busy
with the input/output, the CPU at that time will be idle. Once the program is finished with
the 1/0, CPU will be allocated to it for the processing. This type of environment is known
as a single-user environment, where the entire CPU is dedicated to a single user.

The only limitation of a single-user system is that the CPU is not utilized fully. To
minimize such a wastage of CPU, another type of operating system is introduced, which is
known as a multi-user environment. Here one CPU is connected to a number of users who
have the independent I/O devices. Initially, all the users are doing I/O and whenever one of
the programs sends a request for the CPU, it is allocated to that program. In such a manner,
a queue of these requests is made and CPU caters to each of these requests one by one. In
this manner, the CPU time, which was getting wasted earlier the single-user system, is being
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utilized now on a proper manner.

The operating system DOS provides a single-user environment for the user, whereas
some other operating systems like UNIX and XENIX are multi-user systems.

1.3 FUNCTIONS PERFORMED BY AN OPERATING SYSTEM

An operating system is an irreplaceable part of a computer system. A number of
important functions are handled by an operating system, some of which are listed as follows:

1.3.1 Memory Management

Memory is one of the important components of the computer system. A program must
be loaded in the memory for execution. As the program executes, it accesses program
instructions and data from memory. When the program terminates, the memory space
occupied by it is cleared and is marked as available. The operating system is responsible for
the memory management. A number of memory management schemes are available but a
suitable scheme is adopted by the o/s depending on the hardware design of the system.

1.3.2 Device Management

A number of devices are connected to the computer system. In case of a multi-user
system a device is allocated to a user when his job is finished , the device is released. Other
operations like read, write, etc. are also performed on the devices. It is the Operating system
which is responsible for the proper scheduling and management of these devices.

1.3.3 Process Management

An operating system enables a running program (also referred to as a process) to call
other programs abort itself, to create a new process, etc. All these operations are performed
by the system calls of the operating system.

1.3.4 Information Management

The operating system keeps information about all its processes, using system calls to
access this information. Transfer of information takes place between the user programs and
the operating system with the help of these system calls. They return information about time,
date, system information system.

1.4 MS-DOS

MS-DOS or the Micro Soft Disk Operating System consists of a group of programs
which perform the following functions:

© to monitor commands given by the user to the computer,
© to load and execute programs specified by the user,
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O to manage the devices attached to the computer,
© to manage the files of data and programs that the computer will work with.

The MS-DOS is a single users OS which means that only one user can use the

computer at a time. It allows the user to enter the commands in upper case letters, lower case
letters or a combination of both. All the DOS commands are terminated by [Enter| key. The
important commands of DOS are described below :

1.4.1

ATTRIB Command

This command allows to set the read attributes of a file to read-only or to display the

attributes of a file. The syntax is:

[path]ATTRIB [+R| -R] [+A] -A] [+S]| -S] [+H] -H] [path] filename.ext /S

where,

1.4.2

[path] before ATTRIB specifies the path of the ATTRIB command file.
+ Sets an attribute.

Clears an attribute

Read-only file attribute

Archive file attribute

System file attribute

Hidden file attribute

/S Processes files in all directories in the specified path
filename.ext File whose attributes are to be modified.

el S

BACKUP Command

This command backs up one or more files from a disk to another disk. The drive

specifiers of the disks must be different. The syntax is :

where,

1.4.3

[path]BACKUP d:[path]filename d: [/S][/M][/D:mm-dd-yy]

[path] before BACKUP specifies the path of the BACKUP command file.
d:[path]filename specifies the filenames to be backed up.(Source)

d: specifies the drive that will contain the backed up files.(Destination)

/S is used to backup all the files in all the subdirectories in addition to the files in the
specified directory.

/M is used to backup files that have been modified since the last backup.

/D is used to back up files that have been modified on or after the specified date. The

format of the date specified will be mm-dd-yy.
CD Command
This command changes the working directory. The syntax is :

CD <directory_name >
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8.
CD \IRCC
will set the working directory as \IRCC.
1.4.4 CHKDSK Command

[t shows the space available on a hard disk or floppy. The syntax is:
CHKDSK

1.4.5 CLS Command
This command clears the screen.

1.4.6 COPY Command
This command copies the contents of one file to the other file. The syntax is:
COPY <file one> <file two)

G COPY ABC.EXT XYZ.EXT

As a result of the above command there will be two files in the directory with same
contents but with different names ABC.EXT and XYZ.EXT.

1.4.7 DATE Command
This command is used to change the date known to the DOS. The syntax is:

DATE [mm-dd-yy]
where mm-dd-yy specifies the date in month-day-year format.

1.4.8 DEL or ERASE Command
It deletes selected files. The syntax is:

DEL < filename.ext>
or ERASE < filename.ext>

e.g.
DEL RAJEN.BAK
will delete the file RAJEN.BAK from the current directory.
1.4.9 DELTREE Command

This command can be used to delete a directory along with all the files and
subdirectories. The syntax is :
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DELTREE c:\fortran
1.4.10 DIR Command

It gives the information about the file like, file name, extension, size of the file in
bytes and date and time the file was last edited. e.g.

DIR
will display all the file in current directory.

DIR/P
will display directory, pausing after every screenful to enable the user to examine the
list.

1.4.11 DOSXEY Command

This command loads the DOSKEY ( a memory resident program) in the memory.
Doskey can be used to recall/ edit the previously used commands by using the arrow keys
on the keyboard. To load Doskey, at the DOS prompt type :

[path] DOSKEY
1.4.12 MD Command

This command is used for creating a directory in the current directory. The syntax
is:

MD < Directory name >
e.g.

MD IRCC

will create a subdirectory IRCC in the current directory.
1.4.13 PATH Command

This command sets specified directories for commands or batch files that were not
found by a search of the current directory. The syntax is :

PATH [pathl;path2....... |

A list of drives and path names, separated by semicolons can be specified.
1.4.14 PRINT Command

This command prints a file. The syntax is :

PRINT < filename >
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1.4.15 PROMPT Command

This command is used to set a new DOS prompt. The syntax is :
PROMPT [prompt text]
1.4.16 RD Command
This command is used for deleting a directory or sub directory. The syntax is:
RD <directory name >

The directory being deleted should not contain any file i.e. the directory should be
empty.

1.4.17 RENAME Command
It changes the name of selected file. The syntax is:

RENAME <oldfile_name > < newfile name >

e.g.
RENAME ABCD.FOR KKK.FOR
will rename the file ABCD.FOR to KKK.FOR.

1.4.18 RESTORE Command

This command restores one or more backup files from a disk to another disk. The
syntax is:

[path|RESTORE d:[/S]

where,
[path] is the path of the RESTORE command file.
d: is the drive that contains the backup files.
/S is used to restore all files in all the subdirectories in addition to the files in the
specifies directory

1.4.19 SYS Command

This command transfers the operating system files from the first drive specified to the
second drive specified. The syntax is :

[path]SYS d:
where,
[path] before SYS specifies the path of the SYS command file and
[d:] specifies the disk drive where the operating system files are to be transferred
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1.4.20 TIME Command

Whenever any file is created or modified, the time of creation/modification of that
file is recorded in the system. This command permits to change the time known to the
system. The syntax is :

TIME [hh:mm:ss]

where, hh specifies the hours, mm specifies the minutes and ss specifies the seconds.

1.4.21 TREE Command

This command displays all of the directory paths found on the specified drive, and
optionally lists the files in each subdirectory. The syntax is:

[path]TREE d:][/F]
where,
[path] before TREE specifies the path of the tree command file
[d:] specifies the drive whose directory paths are to be displayed and
[/F] is optionally used to display the names of the files in the subdirectories.

1.4.22 TYPE Command
It displays the contents of an ASCII file on the screen. The syntax ig
TYPE <filename.ext>
e.g.
TYPE RAJEN.DAT
will display the contents of file RAJEN.DAT on screen.
1.4.23 XCOPY Command

This command copies file (except hidden and system files) and directory trees. The
syntax is :

XCOPY source [destination] [ /D:date] [ /P] [/S [/E]] [/V] [ /W]
where,

source the files to copy
destination  the location of new files.
/D copies files changed on or after the specified date
/P prompts before creating each destination file
/S copies directories and subdirectories except empty one
/E copies any subdirectories, even if empty
A% verifies each new file
IW prompts the user to press a key before copying
Training course on "Software for Groundwater Data Management”, National Institute of Hydrology, Roorkee.



Operating System and File Editors / S.K. Jain

1.4.24 Changing the Drive

To change the drive type the drive name followed by colon( : ) sign (without any
blank). e.g.

A:

The default drive will be A: now.

1.4.25 Halting the rushing text

When a program puts out many lines of data in rapid succession the user need a way
to stop the flow of text so that it can be read before it rolls off the screen. Press [Ctrl] and
[S] keys simultaneously for halting the flow of text. Press any key to restart the flow of text.

1.4.26 Copying file from one floppy to other floppy

When system contains only one floppy drive, floppy swapping is necessary, e.g. if
a file is to be copied from *X” floppy to *Y” floppy, with floppy "X" is in drive A, type the
following :

COPY A:<filename> B:
As a result the file <filename > will be copied from floppy X to floppy Y.

For copying the whole floppy, DISKCOPY command is used which also formats the
target floppy. The syntax is:

DISKCOPY A: B:
[t will format the target floppy and copy all the files from A drive to B drive.

1.4.27 Copying file from floppy to directory on hard disk

Insert floppy in drive A and type:
COPY A: <filename> c: <directory name >
e.g.
COPY A:*.*c: IRCC
will copy all the files of floppy to IRCC directory.

The user may note that the exact command syntax and behaviour may slightly change
from one version of the DOS to other.

1.4.28 MS-DOS Diagnostics and MS-DOS Antivirus Utilities

MS-DOS Diagnostics (MSD) provides the detailed technical information about the
computer. MS-DOS Antivirus (MSAV) can protect the data by detecting more than 800
different viruses and removing them from the system. It also includes VSAFE, a memory
resident program that monitors the computer and warns of changes that might have been
caused by a virus.
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1.4.29 Configuring the System

To configure the system, the user sets it up so that MS-DOS, hardware and the
applications work in the way required. Most of the system’s configuration information is
stored in two files :

CONFIG.SYS is a text file that contains commands that configure the computer’s hardware
components (Memory, keyboard, mouse, printer and so on) so MS-DOS and other
applications can use them. When the MS-DOS starts, it carries out the commands in
CONFIG.SYS file first.

AUTOEXEC.BAT file is a batch program that MS-DOS runs immediately after carrying out
the commands in the CONFIG.SYS. The AUTOEXEC.BAT can contain any DOS command
that is to be executed when the system is started e.g. commands that define the path; run
your favourite menu program etc.

These two files are typically located in the root directory of the boot disk.

The following is a typical CONFIG.SYS file for a 80386 computer with 2 MB or
more of extended memory :

device = c:\dos\setver.exe
device = c:\dos\himem.sys
device = ¢:\dos\emm386.exe ram
devicehigh = c:\mouse\mouse.sys
buffers = 20
files = 4()
break = on
dos = high,umb
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Some commonly used commands of the CONFIG.SYS are as follows

Command  Purpose

break Specifies whether MS-DOS should check periodically for the
CTRL+C or CTRL+BREAK key combination.

buffers Specifies how much memory MS-DOS reserves for transferring
information to and from disks.

country Sets the language conventions for your system.

device Loads an installable device driver program that controls a
hardware component, such as a mouse or memory board.

devicehigh  Loads an installable device driver into the upper memory area.

dos Specifies whether MS-DOS will use the high memory area
(HMA) and whether it will provide access to upper memory
biocks (UMBs).

files Specifies how many files can be open at a time.

install Loads a memory-resident program (also called a terminate-and-
stay-resident program, or TSR).

lastdrive Sets the number of valid drive letters,

numlock Specifies whether the NUM LOCK setting of the numeric keypad
is initially on or off,

rem Indicates that the text that follows is a descriptive remark, not a
command. It can also be used to disable a command.

set Sets the value of environment variables such as PROMPT or
TEMP

shell Configures COMMAND.COM or specifies that a command
interpreter other than COMMAND.COM should be used.

2.0 MS WINDOWS OPERATING SYSTEM

Windows is an operating environment. It can be called user interface methodology
where user need not concern himself with how windows work, because the goal of windows
application developers is to use the windows environment with more visible continuity. The
user can do most of the usual chores by making selections from the menus and need not
remember or type the various commands. Extensive on-line help is available to guide him
at the various stages. It is a GUI (Graphical User Interface) combined with support of
standardized methods. MS WINDOWS 3.1 and WINDOWS 95 are the two most commonly
used window softwares. Instead of being a full operating system, Microsoft had originally
developed Window 3.1 as an add-on over MS-DOS. However, the Windows-S5 has been
developed as a full fledged OS.

The Windows-95 is an operating system, it bypasses DOS and runs completely in

protected mode. It can however stop briefly in real mode at start up to process the now-
optional CONFIG.SYS and AUTOEXEC.BAT, to load TSRs and old device drivers. With
Training course on "Software for Groundwater Data Management”,
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Windows-95 INI files will be a history, crucial configuration details like user preferences,
hardware settings and security are stored in the Registry - a database user can distribute
across a Windows-95 network. The OS also expands and contracts its cache buffer space to
match available memory - thus ending swap-file tinkering and cache memory problems. The
Windows-95 is 32-bit operating system but Microsoft has left some 16-bit code in so that it
can run on 4MB systems.

2.1 Why Use Windows?

Some reasons why windows is becoming popular around the world, are:

o It is an easy-to-use, consistent GUI for virtually all programs.

o It is capable of multitasking (running several programs simultaneously). Graphics
programs and character based programs can be run concurrently.

o It can be used to switch easily between multiple program.

o With windows, user can communicate and exchange data between programs without
transferring or copying files.

o As file and disk-management are simple and readily available, a user need not close
and open programs or use DOS commands to do standard file and disk-maintenance
chores.

o Windows can run applications that offer high quality output.

o Many specific purpose and utility programs are bundled with windows.

2.2 MS WINDOWS 3.1
2.2.1 Requirements To Run Windows 3.1
Windows runs on two operating modes depending upon hardware configuration.

(i) For PC 386 enhanced mode:
A personal computer with a 386 processor or higher having:
O 640 K conventional mz nory,
© 1024 K extended memory,
O 8-MB of free disk space, 10 MB recommended,
O One floppy disk drive.

(i) For Standard mode:

A personal computer with a 286 processor or higher or 386 that has less than 2-MB
of free Memory having :

© 640 K of conventional memory,

256 K of extended memory,
6- MB of free disk space,
One floppy disk drive,
A display adapter that is supported by windows,
A printer that is supported by windows,
A mouse that is supported by windows,
A modem if terminal is to be used for windows application.

OO0 O0OO0O0O0O0
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2.2.2 Running Programs Simultaneously

Depending on available hardware, doing several tasks simultaneously is made easy
through windows. For example, when the user switches from painting program to word
processor he has to exit the painting program, go to MS-DOS and then start the word
processor. Leaving programs can be slow; starting programs usually is even slower. With
windows, switching between programs takes small time.

2.2.3 Communication Among Windows Programs

Two major methods for passing information are clipboard and OLE (Object Linking
and Embedding). Most of interprogram communication is done through the clipboard.

2.2.3.1 Clipboard
Clipboard is a buffer or holding area in system memory that contains one piece of
data at any one time. Read and write is done through standard commands.

2.2.3.2 OLE (Object Linking & Embedding)

OLE is a method for passing data directly between programs without having to use
the clipboard. It can be thought of as a telephone network on which one program can dial
another program and pass on certain types of information.

2.2.4 Starting And Leaving Windows 3.1

2.2.4.1 Starting Windows 3.1:

C> WIN
It automatically runs Program Manager.

2.2.4.2 Running Programs As You Start Windows 3.1:
If the user provides the name of program on MS-DOS command line, WINDOWS
starts that program rather than the Program Manager:
C : > WIN \WORDS\WORD
This will start the windows and then the word program from the WORDS directory.

2.2.4.3 Leaving Windows 3.1:
As windows is an operating environment and is not a single program, it requires a
DOS shell to run:

o) When user exits from other windows programs, control returns to program
manager. When the program manager is in the front window, give the Exit
command in the file menu or press Alt-F4.

o When user closes Program Manager he is presented with a dialog box
confirming that he wants to leave windows. Press OK to leave windows. To
resume working in windows press Cancel or Esc key..

Training course on "Software for Groundwater Data Management”, National Institute of Hydrology, Roorkee.
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2.2.5 Menus & Commands

The most common way to tell windows what user wants to do is by choosing a
command from a menu. Every windows program has at least one menu and most have four
or more. The menu bar is at the top of the program window. The Program Manager menu
bar has the following pull down menus :

O File
© Options
© Window
O Help

2.2.5.1 Elipses and Check Marks

In some commands, elipses (_ _ _) follows the command name. In file menu the
commands such as New, Move, Copy etc. have eclipses but others like Open and Delete do
not. An elipse indicates that the command does not execute directly. Some more information
is needed for its execution. The command displays a dialog box through the user can make
additional choices or supply the requisite information before the command executes.

Sometimes commands have a check mark to their left. The check mark indicates that
the particular marked command is currently active or selected. The check mark is absent
when the command is unselected or when it is inactive. Check marks are ON/OFF indicators
and are sometimes called toggles.

2.2.6 Main Windows Manager Programs

2.2.6.1 Program Manager

o Program Manager organizes user programs into groups.

o The central program from which user can run other programs is the windows
Program Manager.

o The user sees this program running when he first starts windows and again when he
is about to leave windows.

o Its features is its flexibility.

o User can easily change the ways programs appear in Program Manager, rearrange the
programs, add new ones, remove old ones and so on.

o User can configure how programs should run whether they should run at the start and

what documents to open when program starts.

After installation, the Windows has five program groups (holding related programs),
represented by their icons. These are as follows: '

O Start-up O Main O Accessories
O Application © Games

When windows starts it looks like as in Fig. 1

Training course on "Software for Groundwater Data Management", National Institute of Hydrology, Roorkee.
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A. Menus In Program Manager
The four menus of Program Manager are File, Options, Windows and Help. The File
menu is displayed in Fig.2.

B. File Menu

Operating System and File Editors / S.K. Jain

File

New coeeee

Open

Move .....

Copy .....

Delete ....
Properties .....
Run ......

Exit Windows .....

Enter
F7
F8
Del

Alt + Enter

Fig. 2. File Menu

The various commands of the file menu are explained in Table 1.
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Table - 1
Command Function
New Creates new program groups and icons.
Open Opens the application icon that has a high-lighted text.
Move Moves icon from one group to another.
Copy Makes a copy of a highlighted icon from one group in
another desired group.
Delete Removes the selected icon or group permanently.
Run Starts an application or opens a document.

Exit Windows Command to leave windows.

C. Options Menu
The Options menu is shown in Fig. 3.

Options
Auto Arrange
Minimize on Use

Save Settings on Exit

Fig.3 . Preferences chosen from options menu.

The various commands of the options ménu are explained in Table 2.

Table - 2
Command Function
Auto Arrange Arranges icons automatically.
Minimize on Use Causes the last program used to change to an icon
Save settings on Exit Indicates whether changes to windows environment
will be saved upon exit.

D. Window Menu

The window menu, shown in Fig. 4, is used to arrange the appearance of icons.

Training course on "Software for Groundwater Data Management”, National Institute of Hydrology, Roorkee.
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Window
Cascade
Tile

Arrange Icons
O Main
O Game

Shift + F5
Shift + F4

O Startup
O Accessories

O Applications

Fig.4 : The Window menu with main group chosen.

The various commands of the window menu are explained in Table 3.

Arrange Icons
Available Groups

Table - 3
Command Function
Cascade Displays the window opened below and to the right
of each other.
Tile Divides the screen equally between the opened

windows.

Enables the space icons manually.

List of the program groups available for use in
windows.

E. Help Menu

This menu is shown in Fig. 5. Its commands are explained in Table 4.

Contents

Search for Helpon _
How to use Help

Windows tutorial

About Program Manager

Fig.5. Help Menu of Program Manager.
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Table - 4
Command Function
Contents Displays a table of topics covered in Help.
Search for Help Shows a detailed alphabetical list of topics in Help
on from which user can make a choice.
How to use Provides tips and techniques to use Help.
Help On-line lessons to know the windows basics.
Windows tutorials | Information about the user’s copy of Program
About program Manager, its operating mode, memory capacity and
available system resources.

2.2.6.2 File Manager

)

File manager can be started from the Program Manager by double clicking its
icon in the Main group window.

File manager provides a graphical representation of files and directories and
help the user to organize and simplify file maintenance.

The directory window is divided by the split bar. The left side of the window
displays the structure of the current drive, or the directory tree. The right side
of the window displays a list of files in the selected directory as seen in Fig.6.
User can use the drive icons on the drive bar to choose what drive is
displayed in a directory window.

Status bar displays information about the current drive and directory and other
information that helps explain the task user is performing with File Manager.
The Menu bar contains menus listing File Manager Commands.

Task Performed By File Manager

With the File manager, a user can:
¢ View the contents of directories.
Move, copy and delete files and directories.
Change to other disk drives, including network drives.
Format and maintain disks.
Print documents.
Start an application.
Rename and delete files.

LS RS I C "R I e
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¢ Change the kind and amount of information displayed about each file.

¢ Create directories and subdirectories.

¢ Search for files.
2.2.6.3 Print Manager

The Print Manager is an application included with Windows that the users can use to

manage documents sent to a printer and can install and configure printers, as shown in Fig.
7. Whenever a user prints from a windows based application, the application creates a print
file and sends it to Print Manager. Print Manager works in background, sending users
documents to the printer while the user can continue working. The user can check the status
of the document at any time and change its status until it starts printing.

As user sends documents to Print Manager, a print queue forms. The point queue
displays the following information:

> The name of the printer.
32 The port printer is connected to and, if it is a network printer, the network path.

=5 The current status of the printer (such as native or idle).

= Beneath the printer information, the print queue displays the following document
information.

<> The title of the document.

=% The document’s position in the queue, or a printer icon if the document is printing.

=% The size of the document in kilobytes (if the Print file size command has a check

mark next to it).

= The time and date user sent the document to Print Manager.

> [f a document is currently printing, the amount (as a percentage) of the document
printed so far.

To Pause Printing

@ In print Manager window, select the name of the printer to be paused.
o Choose the Pause button, Or press ALT + P.

To Resume Printing
o In print Manager window, select the document or the name of the printer you want

to resume printing.
o Choose the Resume button. Or press ALT + R.

Training course on "Software for Groundwater Data Management”, National Institute of Hydroelogy, Roorkee.
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To Cancel Printing

O
O

In print manager, select the document whose printing is to be cancelled.
Choose the Delete button. Or press ALT + D. A dialog box appears, prompting to
confirm the deletion.

2.2.7 Other Programs That Come with Windows

L&

3

Write a word processor that can prepare letters, reports and articles.

Paintbrush a painting program that can create colour or black & white drawings.
Calendar an appointment calendar that helps a user organize his time and alerts when
important events are about to take place.

Cardfile an organizing program that a user can use to store and search for
information.

Terminal a communications program for connecting the users” PC to other computers
through a modem.

Calculator a desk calculator that can replace the old pocket model.

2.2.8 Keyboard Shortcuts

A user can use keyboard shortcuts to do common windows tasks.

2.2.8.1 Using Help

»

»

To Press
Start Help F1
Move among jumps in a topic TAB or SHIFT + TAB
Display all the jumps in a topic or Ctrl + TAB
cancel the selection of a jump
Copy a Help screen or annotation ALT + PRINT SCREEN
into the clipboard
Quit Help ALT + F4

2.2.8.2 Switching Between Applications

To switch Do this
» Between applications Press and hold down ALT or SHIFT +
ALT and repeatedly press TAB
» To the next application Press ALT + ESC
Training course on "Software for Groundwater Date Management”, National Institute of Hydrology, Roorkee.
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To the previous application

To task list

An MS-DOS based application from
a full screen to a window and back

2.2.8.3 Using Menus

»

»

»

To
Activate the menu bar
Select a menu

Choose a n.enu command

Open the control menu for an
application window

Open the Control menu for a
document window and a group

window.

2.2.8.4 Moving Around

»

»

»

»

To move
Between menu commands, characters
in a text box, or items in a list.
To next or previous dialog box item
To a dialog box item

Right or Left one word in a text box
To beginning or end of a line,

list, or screen

Up or Down one screen

2.2.8.5 Selecting Items

»

Training course on "Software for Groundwater Data Management",

In a Document Window
To select
One line of text up or down
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Press SHIFT + ALT + ESC
Press Ctrl + ESC
Press ALT + ENTER

Press

ALT or F10

ALT+the underlined character in the
menu name

An arrow key, ENTER or the under-
lined character in the command name.
ALT + SPACE BAR

ALT + HYPHEN

Press
An arrow key

TAB or SHIFT + TAB

ALT + the character underlined in the
item name.

Ctrl + an ARROW key.

HOME or END

PAGE UP or PAGE DOWN

Press
SHIFT + UP arrow or SHIFT +DOWN

arrow

National Institute of Hydrology, Roorkee.




» Text to the beginning or end of a
document
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SHIFT + Ctrl + HOME or
SHIFT + Ctrl + END

In a Document Window, Text Box. or List

To Select
» Text to the beginning or end of a line
» The next or previous word
» One letter at a time to left or right

In a Dialog Box

To Select
» Select nonconsecutive items in a list
» Select a list item or check box
» Select all items in a list
» Cancel all selections in a list except

the current one

2.2.8.6 Editing Text
In a Text Box or Window
To
» Delete the character to the left or
right or delete selected text.

» Copy selected text into the clipboard
» Move selected text into the clipboard
» Paste text from the clipboard

» Undo the last editing action

2.2.8.7 Copying Onto the Clipboard:
To

» Copy an image of the entire screen
onto the clipboard.
» Copy an image of the active window

Press
SHIFT+HOME or SHIFT+END
SHIFT + Ctrl + Right Arrow or SHIFT
+ Ctrl + Left Arrow
SHIFT + Left Arrow or SHIFT + Right
Arrow

Press
SHIFT + F8, Use arrow key to move
item to be selected, press SPACEBAR to
select item, press SHIFT + F8 again.
SPACEBAR
Ctrl + SLASH (/)
Ctrl + BACKSLASH (\)

Press
BACKSPACE or DEL

Ctrl+ C or Ctrl + INS

Ctrl + X or SHIFT + DEL

Ctrl + V or SHIFT + INS

Ctrl + Z or ALT+BACKSPACE

Do this
Press PRINT SCREEN

Press ALT + PRINT SCREEN

Training course on "Software for Groundwater Data Management”, National Institute of Hydrology, Roorkee.
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on to the clipboard.

Operating System and File Editors / S.K. Jain

2.2.8.8 Quitting an Application & Closing a Window

»

2.2.8.9

To
Quit an application
Close the active document window
or group window.

Program Manager
To

Move between groups

Move between items in a group window
Start the selected application or restore
the selected group icon.

File the group windows

Cascade the group windows

Close an active group window

2.2.8.10 File Manager

»

To
Move among the left and right side of
the directory window and the drive bar.
Change the drive displayed in the

Display or hide a selected directory’s
subdirectories, start a selected appli-
cation, or open a selected file.

Open a new window, display only the
contents of the selected directory.
Select the next file or directory whose
name begins with a certain character
Move the selected file or directory.
Copy the selected file or directory.
Update the information displayed.
Display the properties of the selected
file or directory.

Training course on "Software for Groundwater Data Management”,
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Press
ALT + F4
Ctrl + F4

Press

Ctrl + F6 or Ctrl + TAB
An arrow key
ENTER

SHIFT + F4
SHIFT + F5
Ctrl + F4

Do this
Press TAB or F6

Press Ctrl + the letter representing

directory window.
Press ENTER

Press SHIFT + ENTER

Press the first character or file
or directory name. Press F7.

Press F8

Press F5
Press ALT + ENTER

National Institute of Hydrology, Roorkee.
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2.2.8.11 Print Manager

To Press
» Move between queues and between Up Arrow or Down Arrow
documents in each queue.
» Move the selected document up or Ctrl + UP ARROW or
down in a queue. Ctrl + DOWN ARROW
» Update the information displayed Press F5

2.2.8.12 Write

To Do this
» Undo the last typing or editing action Press C+Z or ALT+Backspace
» Insert a manual page break Press Ctrl + ENTER
» Insert an invisible hyphen Press Cirl + SHIFT + HYPHEN
(only to be used when a word is wrapped).
» Switch between the document and Press ALT + F6
» Find or Replace dialog box or between

the Header and Footer window and the
» Page Header or Page Footer dialog box.

3.0 MS-DOS EDITOR

MS-DOS Editor is a useful tool for customizing the system. Files created by MS-DOS
Editor are unformatted text files. It is a text editor which can be used to create, edit, and
print memos, letters, and special files that customize MS-DOS. While working with MS-DOS
Editor, both the keyboard and a mouse can be used.

Using MS-DOS Editor, the following operations can be performed:

o Choose commands from menus and specify information and preferences in dialog
boxes.

O Select text and move, copy, or delete it.

o Find and replace the specified text.

o Use Help to find information about MS-DOS Editor procedures and commands.

Training course on "Software for Groundwater Data Management”, National Institute of Hydrology, Roorkee.
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3.1 Getting Started with MS-DOS Editor
There are two ways to start MS-DOS Editor:

O At the command prompt
© In MS-DOS Shell.

3.1.1 To start MS-DOS Editor at the command prompt:

Type edit at the command prompt. To open an existing text file include its path and
filename, as in the following example:

edit d: \work\program. txt
MS-DOS Editor starts with the PROGRAM.TXT file loaded.
3.1.2 To start MS-DOS Editor from MS-DOS Shell:

(a) Using Mouse
o In the Main group, double-click Editor. The File to Edit dialog box appears.
O To create a new file, click OK.

To edit an existing file, type its path and filename in the File to Edit box, and then
click the OK button.

(b) Using Keyboard

o Press TAB to move to the Main group.

o Use the Up ARROW or DOWN ARROW key to move the selection cursor to Editor,
and then press ENTER. The File to Edit dialog box appears.

o To create a new file, choose the OK button.

To edit an existing file, type its path and filename in the File to Edit box, and then
choose the OK button.

While tying only the word edit at the command prompt, or choose the OK button in
the File to Edit box without specifying a filename in MS-DOS Shell, the following screen
appears:

To get information about MS-DOS Editor when this screen appears, press ENTER
or click the phrase, "Press Enter to see the Survival Guide.” An introduction to MS-DOS
Editor and its Help system is then displayed.

To start working with MS-DOS Editor, press ESC or click the phrase, "Press ESC

to clear this dialog box." An empty window appears. Work on text files by typing or editing
text in the window.

Training course on "Software for Groundwater Data Management"”, National Institute of Hydrology, Roorkee.
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If a filename is specified while starting the MS-DOS Editor, then that specified file
appears instead of the dialog box. To get information about MS-DOS Editor after a file has
been loaded, press F1.

3.1.3 Working with Menus

To perform tasks in MS-DOS Editor, choose commands from menus on the menu bar,
The menu bar is displayed at the top of the MS-DOS Editor window.

O To select a menu

Using Mouse : Click the name of the specified menu.
Using Keyboard
- Press ALT. The first menu name, File, is selected.
- Press the LEFT/RIGHT ARROW key to select the required menu and
press ENTER. Or type the first letter of the menu name.

O To choose a command:
Using Mouse : Click the command.
Using Keyboard : Press the UP/DOWN ARROW key to select the required
command, and press ENTER. Or press the highlighted letter in
the command name.

There are some commands (e.g. cut, copy, paste etc) which do not have a highlighted
letter. Before using these commands some necessary action is to be performed on which the
required command is to be applied. For example, to use Cut command, it is necessary to
select some text.

There are some commands which can be chosen by using shortcut keys. If a command
has a shortcut key, it is displayed next to the command name on the menu.

© To cancel a menu without choosing a command:
Using Mouse : Click anywhere outside the selected menu.
Using'Keyboard  : Press ESC.

O Working with Dialog Boxes

While choosing some commands, a dialog box appears. Type additional information
or select options in a dialog box. For example, to choose the Open command from the File
menu, the Open dialog box appears. Most dialog boxes have areas where one can type
information or select options. To move from one area to another press TAB. (To move in
reverse order, press SHIFT+TAB.) While using a mouse, click the required area needed o
work in.

Most dialog boxes contain one or more of the following items:
A text box in which a text can be typed. If the selected box already contains text,

Training course on "Software for Groundwater Data Management", National Institute of Hydrology, Roorkee.
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clear it by typing characters or by pressing the SPACEBAR.

- A group of options with a dot next to the currently selected option. Select an option
by clicking between the parentheses next to the required option, or moving the dot
by using the arrow keys.

- Check boxes (select or clear). To select a check box, click it; or use TAB using to
move the cursor to the check box, and then press the SPACEBAR. To clear a check
box, click it again; or press the SPACEBAR again.

- A list of files, directories, and drives.

- Command buttons, such as OK, Cancel, and Help (located along the bottom of the
dialog box.

The OK button carries out the command and closes the dialog box. When the angle
brackets around the OK button are highlighted, press ENTER to carry out the command, or
click the OK button.

The Cancel button cancels the command and closes the dialog box. There are three
ways to cancel a command: by using TAB to select the Cancel button and then pressing
ENTER; by pressing ESC; or by clicking the Cancel button.

The Help button displays information about the command. There are three ways to
get Help: by using TAB to select the Help Button and then pressing ENTER; by pressing F1;
or by clicking the Help button.

O To select an item from a list in a dialog box:

Using Mouse : Click the required item. If the required item is not visible,
click the scroll arrows until it comes into view. Alternatively
drag the scroll box in the scroll bar, or click the shaded areas
of the scroll bar.

Using Keyboard :  Press TAB to move to the list. Use the arrow keys to move the
selection cursor to the required item. The HOME, END,

PAGE UP, and PAGE DOWN keys can also be used to move
the selection cursor.

3.2 Using Help

There are several types of Help available in MS-DOS Editor. The following sections
describe how to use the different kinds of Help.

Training course on "Software for Groundwater Data Management”, National Institute of Hydrology, Roorkee.
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3.2.1 Status Bar

One type of help, which is always available at the bottom of status bar that displays
information about commands or keys that can be used. When one use a command, the status
bar displays a short description of it. For more information about the command, press F1.

The status bar changes while selecting a menu, choosing a command, or opening a
dialog box. It also displays information about the functions of various keys. Use this Help

for a quick reminder about the purpose of a command or for a quick reference to the
keyboard.

3.2.2 Command, Menu, and Dialog Box Help

Obtain Help on how to use a specific command, menu, or dialog box by selecting the
item and pressing Fl. Help can be cancelled by pressing ENTER or ESC.

In a dialog box, Help can also be obtained by clicking the Help bution. Use this Help
for knowing how to use a specific command, menu, or dialog box.

3.2.3 Survival Guide

MS-DOS Editor also has Help for getting started with MS-DOS Editor and Help for
using the keyboard to navigate through text and Help. This Help is called the Survival Guide.
It looks different from the other types of Help in MS-DOS Editor. The Survival Guide
contains information about editing keys, cursor movement, dialog box, selecting text,
opening and saving files, and other basics.

Use this Help while learning how to use MS-DOS Editor or when Help is needed
during navigating through text.

The Survival Guide can be used by doing one of the following:

o From the Help menu, choose Getting Started or Keyboard.

o} When in the MS-DOS Editor window, press F1.

o Immediately after starting MS-DOS Editor (and without specifying a file),- press
ENTER.

When the Help window appears, one can choose to view any of the related topics
enclosed in the highlighted angle brackets. To view a related topic, move the cursor to it and
press ENTER, or double-click the topic.

The following keys can be used to move the cursor from one topic to the next in the
Survival Guide:

TAB Moves the cursor to the next Help topic.
SHIFT+TAB Moves the cursor to the previous Help topic.
Training course on "Software for Groundwater Data Management”, National Institute of Hydrology, Roorkee.
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A character Moves the cursor to the next Help topic beginning with that
character.

SHIFT +a character Moves the cursor to the previous Help topic beginning with
that character.

ALT+F1 Displays the Help window for a previously viewed help topic.

CTRL+F1 Displays the rext Help topic in the Help file.

SHIFT+CTRL+F1 Displays the previous Help topic in the Help file.

3.2.4 Specifying the Help Path

MS-DOS Editor uses a file named EDIT.HLP to display Help messages. MS-DOS
looks for this file in the current directory and any directories specified by the path command.
If the EDIT.HLP file is not found, MS-DOS Editor cannot display Help.

One can specify the location of the EDIT.HLP file by using the Help Path command
on the Options menu.

3.2.5 To specify the Help path

© From the option menu, choose Help Path. The Help Path dialog box appears.
© Type the path of the directory that contains EDIT.HLP.

© Choose the OK button.

3.3 Quitting MS-DOS Editor

One can quit MS-DOS Editor and save the working file. To quit MS-DOS Editor
from the File menu, choose Exit.

3.4 Creating a Text File
Create a text file by typing text in the MS-DOS Editor window. Reaching the end of

a line, press ENTER to move the cursor to the next line. A line of text can be up to 256
characters long. The following is a list of keys you can use with MS-DOS Editor:

BACKSPACE or CTRL+H Deletes the character to the left of the cursor.

DEL or CTRL+G Deletes the character at the cursor.

CTRL+T Deletes the word at the cursor (the cursor must be
under the first letter).

INS or CTRL+V Changes from insert to replace mode. The insert mode

is the default. Press INS to replace characters instead of
inserting them. Press INS again to resume inserting.

3.4.1 Moving the Cursor

Both a mouse or the keyboard can be used to move the cursor. Scroll through the text
to see parts of a file that are not visible.

Training course on "Software for Groundwater Data Management”, National Institute of Hydrology, Roorkee.
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Using Mouse : Click the area at the required location of the cursor.
Using Keyboard : Press the arrow keys.

Following keys can also be used to move the cursor through text:

Arrow keys Move the cursor one character or one line
CTRL+LEFT ARROW Moves the cursor one word to the left
CTRL+RIGHT ARROW Moves the cursor one word to the right

HOME Moves the cursor to the beginning of the line

END Moves the cursor to the end of the line
CTRL+ENTER Moves the cursor to the beginning of the next line
CTRL4CAE Moves the cursor to the top of the window
CTRL+0O+X Moves the cursor to the bottom of the window

While working with a file that is longer or wider than the MS-DOS Editor window,
scroll through text to bring it into view.

3.4.2 To scroll through text:
Using Mouse : Click the scroll arrows, drag the scroll box in the scroll bar.

Or click the shaded areas of the scroll bar.
Using Keyboard :  Use the following keys to scroll through text:

CTRL+UP ARROW or CTRL+W Scrolls up one line

CTRL+DOWN ARROW or CTRL+Z  Scrolls down one line

PAGE UP Scrolls up one screen

PAGE DOWN Scrolls down one screen

CTRL+HOME or CTRL+Q+R Moves the cursor to the beginning of a file
CTRL+END or CTRL+Q+C Moves the cursor to the end of a file
CTRL+PAGE UP Scrolls left one screen

CTRL+PAGE DOWN Scrolls right one screen

Scrolling can also be done by holding down an arrow key.
3.4.3 Selecting Text
Most of the editing operations are carried out by selecting a block of text. In a single
line, you can select any amount of text, from a single character to the entire line. One can
also select several lines or the entire file at once.
Using Mouse : Point to the first character to selected. Drag the cursor to the last
character to be selected. Release the mouse button. To cancel a

selection, click anywhere in the window.

Using Keyboard :  Use the arrow keys or other cursor-movement keys to move the cursor
to the first character to be selected. Press and hold down SHIFT, and

Training course on "Software for Groundwater Data Management”, National Institute of Hydrology, Roarkee.
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use the arrow keys to move the cursor to the last character to be
selected. Release the keys. To cancel a selection, press any cursor
movement key.

Once text is selected, it can be deleted by pressing DEL, or edit it by using the
commands on the Edit menu.

3.5 Editing Text

The Edit and Search menus in MS-DOS Editor list the commands used for editing the
text. Using the commands on the Edit menu, one can move or copy a block of text from one
part of a file to another. This can be done by transferring text from the working file to a
temporary storage area called a buffer. Using the Search menu, one can search for a set of
characters in a file. The characters found in a search can be replaced with a different set of
characters.

3.5.1 Moving Text

One can move a block of text by using the Cut and Paste commands. This procedure
is useful to rearrange the order of text in a file.

o Select the block of text to be moved.

o From the Edit menu, choose Cut, or press SHIFT+DEL. The block of text is deleted
from the file and placed in the buffer. One can move all the text from the current line
to the buffer by pressing CTRL+Y. To select text from the cursor location to the end
of the current line and move it to the buffer by first press CTRL+Q, and then press
Y.

o Move the cursor to the location in the file where the text to appear.

o From the Edit menu, choose Paste, or press SHIFT+INS.

The text in the buffer is inserted in the file at the cursor location.

After choosing the Paste command, the text is not removed from the buffer; it
remains there until moving or copying another block of text to the buffer. The text can be
inserted from the buffer into a file as many times as required by repeating the Paste
command.

3.5.2 Copying Text

Use the Copy and Paste commands to copy and reposition a block of text.

o Select the block of text to be copied.

Training course on "Software for Groundwater Data Management”, National Institute of Hydrology, Roorkee.
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From the Edit menu, choose Copy, or press CTRL+INS. The block of text is copied
to the buffer. It is not removed from its original location.

Move the cursor to the location in the file where the block of text it to appear.

From the Edit menu, choose Paste option, or press SHIFT+INS. A copy of the text
in the buffer is inserted into the file at the cursor location. The text remains in the
buffer until one moves or copy another block of text to it. The text can be inserted
into a file as many times as required by repeating the Paste command.

3.5.3 Clearing Text:

The text can be cleared from the MS-DOS Editor window without copying the text

to the buffer. Choosing the Clear command or pressing DEL has no effect on text in the

buffer.

O Select the text required to be clear.
O From the Edit menu, choose Clear or press DEL.

3.5.4 Finding Text

To find text in a file, use the Find command on the Search menu. The text can be a

word, a phrase, or any combination of characters and spaces. When MS-DOS Editor searches
for text, it starts at the current cursor position and selects the first occurrence of the text.

@]

From the Search menu, choose Find option. The Find dialog box appears. If text is
selected before choosing the Find command, the selected text appears in the Find
What box. Otherwise, the word at the current cursor location appears in this box. If
some different text is to be searched, type the text to be searched, in the Find What
box.

To match the capitalization exactly, select the Match Uppercase/Lowercase option.
Otherwise, MS-DOS Editor finds, for example, both Brown and brown.

To find only separate occurrences of the specified text, then the Whole Word option
is to be selected. Otherwise, MS-DOS Editor finds, for example, main in remainder.

Choose the OK button to start the search. MS{DOS Editer begins searching at the
cursor position. The first occurrence of the text is selected. If no occurrences of the
text are found, the Match Not Found dialog box appears.

To search for the next occurrence of the specified text, choose the Repeat Last Find
command from the Search menu, or press F3.

Training course on "Software for Groundwater Data Management", National Institute of Hydrology, Roorkee.
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The Find command continues to search through the file each time one choose the -
Repeat Last Find command. When it reaches the end of the file, it returns to the beginning
and continues searching until it reaches its starting point.

3.5.5 Replacing Text

Use the Change command to find text and replace it with new text. The Change
command begins at the cursor location and continues to the end of the file. When it reaches
the end of the file, it returns to the beginning and continues searching and replacing until it
reaches its starting point.

O Position the cursor where replacing of the text is to be started.
o From the Search menu, choose Change. The Change dialog box appears.
O In the Find What box, type the text to be replaced. In the Change To box, type the

text one want to replace it with.

o To match the capitalization exactly, select the Match Upper/Lowercase option.

O To replace only separate occurrences of the specified text, select the Whole Word
option.

o Choose the Find and Verify/ Change All button to start the command. If one choose

the Find and Verify button, each occurrence of the original text is selected, and the
Change dialog box appears. The dialog box prompts to make the change, skip the
occurrence, cancel the command, or get Help. If the Change All button is chosen,
MS-DOS Editor replaces all occurrences of the specified text.

o Choose the OK button (or press ESC) when the Change Complete dialog box appears.
3.6 Managing Files

Use the commands on the File menu to open an existing file, work on a new file, save
a file, or print a file.

3.6.1 Creating a File
Create a file by using the New command on the File menu.

O From the File menu, choose New option. If one have an open file that has unsaved
changes, MS-DOS Editor displays a dialog box prompting to save the changes.
Choose the Yes button to save the recent changes; choose the No button to close the

file without saving recent changes. MS-DOS Editor closes the current file and
displays an empty window labeled "Untitled." Text can be typed in this window.

Training course on "Software for Groundwater Data Management”, National Institute of Hydrology, Roorkee.

33




Operating System and File fditors / S.K. Jain

o To save the new file, choose the Save or Save As command from the File menu.
Then specify the drive and directory where the file is to be stored, and give the file
a name.

3.6.2 Opening a File

Several types of files can be opened by using the Open command on the File menu:
- Files created previously by using MS-DOS Editor.
- Other unformatted text files (e.g. AUTOEXEC.BAT and CONFIG.SYS)

- Formatted text files created by using another text editor. Special characters may lose
their formatting functions if one open them with MS-DOS Editor.

o From the File menu, choose Open. The Open dialog box appears.

o Type the name of the file to be opened, or select it from the file list. If the specified
file is not on the current drive and directory, type the path as part of the filename.
To view a list of the files on a different drive/directory, move to the Dirs/Drives-list,
select the required drive and/or directory, and double-click it or press ENTER key.
A list of files in the current drive and directory appears in the Files box.

o When the name of the file required to be open is displayed in the File Name box,
choose the OK button.

If a file with unsaved changes is open, MS-DOS Editor displays a dialog box
prompting to save previous changes before opening a new file. Choose the Yes bution to save
changes; or choose the No button to unsave the changes. If one decide not to open the new
file, choose the Cancel button.

3.6.3 Saving a File
After creating a file or making changes to an existing file, save it by using the Save
or Save As command on the File menu. It is a good idea to save the recent work often in

case there is a power loss or equipment failure.

CAUTION : Some files might include special formatting characters. Saving such a file while
using MS-DOS Editor, the special characters lose their formatting function.

© To save a new file:
- From the File menu, choose Save. The Save dialog box appears.

- In the File Name Box, type a name for the file. To save the file on a different drive

or directory, select the drive/directory in the Dirs/Drives box, or include a path while
typing the filename.
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- Choose the OK button.

© To save an existing file:
From the File menu, choose Save.

O To save an existing file under a new name:
- From the File menu, choose Save As. The Save As dialog box appears.

- In the File Name Box, type a name for the file. To save the file on a different drive
or directory, select the drive/directory in the Dirs/Drives box, or include a path while
typing the filename. If ones attempt to save a file in a directory that contains a file
with the same name, MS-DOS Editor displays a dialog box asking for the
replacement of the existing file. Choose Yes button to replace the existing file; choose
the No button to save the file with a different name.

- Choose the OK button.

TIP : Use the Save As command to save a modified version of a file without losing the
original version. For example, if one has a file named MEMO.TXT, keep the original file
as it is and save a modified version as MEMO_2.TXT.

3.6.4 Printing a File

Use the Print command on the File menu to print part or all of an open file. This
command works only if a printer is already connected to or redirected through LPTI
(parallel) printer port.

o Be sure the file to be printed is open. For printing a portion of a file, select that text
portion.

o From the File menu, choose Print. The Print dialog box appears.

o To print only the selected text, choose the Selected Text Only option; otherwise,

select the Complete Document option.
O Choose the OK button.
3.6.5 Printing a Help Topic

Use the Print command on the File menu to print Help information.

o From the Help menu, choose Getting Started or Keyboard.
o Choose the required Help topic to be printed.
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o) Be sure the cursor is in the Help window. To print part Help topic, select the text to
be printed.
o From the File menu, choose Print. To print only the selected text, choose the Selected

Text Only option; otherwise, select the Current Window option.
o Choose the OK button.
3.7 Customizing MS-DOS Editor

Use the commands on the Options menu to set the way, the MS-DOS Editor window
appears.

3.7.1 Controlling the Screen Display

One can use the Display command on the Options menu to change the colors in the
MS-DOS Editor window, display or hide scroll bars, and set tab stops.

3.7.2 To change the screen display:
o From the Options menu, choose Display. The Display dialog box appears.

o To change the screen colors, select a foreground colour and a background colour.
The screen colors depend on the type of monitor. A sample of the selected screen
colors appears to the left of the list boxes. The scroll bars to appear in the MS-DOS
Editor window, select the Scroll Bars option. If this option is not selected, the scroll
bars are hidden and one can see more of the window while working. With the scroil
bars hidden, one can still scroll through text by using the keyboard. To set the tab
stops, set the number of spaces between tab stops. The default is 8.

O Choose the OK button.

The screen display can also be changed by specifying one or more switches when one
type edit at the command prompt.

4.0 NORTON EDITOR

The Norton Editor has been published by the Symantec Corporation while the
copyright of the version 2.0, 1990 lies with S. Reifel & Co. It is a tool used for creating and
modifying text files such as letters, memos and computer programs and computer generated
data. While a number of word processing softwares are available, the most important
application of the NE lies in writing computer programs and analysing the results thereof.

Training course on "Software for Groundwater Data Management”, Natiornal Institute of Hydrology, Raarkee.

36



Operating System and File Editors / S.K. Jain
A number of operations like File operations, Block operations, Text layout operations,
Search operations, Print operations etc. arg helpful in writing and editing a document. These
operations along with the various sub-options are described in the following.
4.1 FILE OPERATIONS

A number of file operations are possible in the Norton Editor. These include opening
a file, saving a file, changing name of file, merging two files, opening two files at a time,
reaching at the top of a file, entering DOS shell without exiting NE etc. Pressing the Alf key
and F key together activates the File Operations. Major options under these operations are
explained below:
4.1.1 Creating a File

Alt-F N creates an empty untitled file. N represents a New file. After the work is
completed, the name is to be given to the file.

4.1.2 Opening a File

Alt-F O loads an existing file. O represents Opening a file before exiting NE.
4.1.3 Saving a File

Alt-F S saves the file being edited. S represents Saving a file. It is advantageous to
keep saving a file while working so as to avoid any work loss due to power failure or
otherwise.
4.1.4 Renaming a File

Alt-F A saves the file being edited with a new name. A represents Save As.

4.1.5 Merging Files

Alt-F M merges another file into the one being edited at the location of the cursor.
M stands for Merging.

4.1.6 Opening Second File

F2 function key opens a new window on the screen to edit a second file. If two
windows are already open, this key moves the cursor from one window to other activating
that particular window. This option is highly useful for analysing the results and testing the
computer programs.

4.1.7 Closing Second File

Alt-F C closes the second window. C represents Closing the second window.

Training course on "Software for Groundwater Data Management”, National Institute of Hydrology, Roorkee.

37




Operating System and File Editors / S.K. Jain
4.1.8 Exiting a File
Alt-F X exits the editor and returns to DOS. X stands for eXiting.

4.1.9 Entering DOS Shell

Alt-F D enters a DOS shell for executing some DOS commands. After executing the
DOS commands, it returns to the existing file in the NE.

4.2 BLOCK OPERATIONS

In editing or creating a text file or a computer program, it is often required to type
a part of the file or program at some other place. Block Operations perform this important
task thereby avoiding the need of retyping. In addition, they also help in printing a certain
part of a long text or in copying certain part in a new file. Block operations are activated by
pressing the ALT and B keys simultaneously. Various important Block operation options are
described below:

4.2.1 Setting a Block

Alt-B § sets a block marker at the cursor. S stands for Setting the marker. For
selecting a block, two markers are required, one at the beginning and the other at the end
of the selected block. Markers may also be set by dragging the mouse with the left button
pressed.
4.2.2 Copying a Block

Alti-B C copies a block of text to the cursor. After setting a block, the cursor is
moved to a place where the block is required to be copied and then the command is pressed.
C stands for Copying.
4.2.3 Moving a Block

Alt-B M moves a block of text to the cursor. In copying, the block at the original
place remains as such while in moving, the block shifts from original to the new place. M
stands for Moving.
4.2.4 Deleting a Block

Alt-B D deletes a block of text. D represents Delete.

4.2.5 Writing Block to a File

Alt-B O writes the block of text into a file. O stands for Qutput to file.
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4.2.6 Finding a Block

Alt-B F moves the curser to the next block marker. F represents Find.
4.2.7 Removing Block Settings

Alt-B R removes tne block markers. R stands for Remove.
4.3 TEXT LAYOUT OPERATIONS

The usefulness of these operations is mostly in preparing a text document rather than
in writing a computer program. These operations are activated by pressing the ALT and T
keys together. Some major options in these operations are described below:
4.3.1 Document Formatting

Alt-T P formats a paragraph of the document in accordance with the settings. P stands
for Paragraph. Alt-T D formats all paragraphs of the document. D represents Document. Alt-
T C centers a line in accordance with the set left margin and line length.

4.3.2 Setting up

Alt-T S sets the left margin and line length used to format paragraphs and centering
lines. Settings are alsc used for word wrap.

4.3.3 Word wrap

Alt-T W toggles word wrap On and Off. Word wrap automatically places a new line
into the file after typing past the set line length. "WW=On" is displayed on the status line
when enabled.
4.3.4 Inserting or Removing Page Breaks

Alt-T I inserts page breaks for printing. Text following the page break is printed at
the top of the next page. The setup dialog box under the Print menu sets the page length. Alt-
T B removes page break characters from the file.

4.3.5 Tabs

Alt-T T replaces spaces at the beginning of all lines in the file with tabs. Alt-T E
replaces all tabs in a file with spaces.

4.3.6 Auto Indent

Alt-T A toggles automatic indent On and Off. Pressing Enter with this enabled creates
a new line and indents the cursor to the same level as the line above. "Auto" is shown on
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the status line when enabled.
4.4 SEARCH OPERATIONS
Especially in writing or editing a computer program, Search Operations are of
immense use. These operations are activated by pressing together the Al and § keys. Various
important options under these operations are discussed below:

4.4.1 Finding a String

Ciri-F searches for a string. Alt-C continues the previous find in the forward direction
while Ctrl-C continues the search in the reverse direction.

4.4.2 Finding & Replacing
Ctrl-R searches for a string and optionally replaces those found.
4.4.3 Searching Line Number

Alt-§ L moves the cursor to the given line number of a file. Dialog box prompts for
line number.

4.4.4 Matching Brackets

Ctrl-] moves the cursor to the opening or closing bracket that mates with the (< {|
13 >) under the cursor.

4.4.5 Search for a Text in Block

Alt-S B searches forward for other copies of the text inside a marked block. Alt-S M
moves the cursor to the next block marker.

4.4.6 Difference Comparison

Alt-S D compares the text between two files. Search begins at the location of each
cursor in the two files. This option is used when both the windows are On.

4.5 PRINT OPERATIONS

Print operations are useful in printing a document. It is activated with the Alf and P
keys pressed together. Various options are as under:

4.5.1 Printing the Text

Alt-P P prints all the text in a file.
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4.5.2 Printing a Block

Alt-P B prints the text in a marked block only. It is useful when only a part of a long
document or program is to be printed.

4.5.3 Setting up Printing
Alt-P § sets the left margin and page length for printing.
4.6 VIEW OPERATIONS

These operations display variety of information. These are activated by Alt and V
keys and works with the following options:

4.6.1 Information Display

Alt-V I displays a variety of data including name of file being edited; length of file
in characters, words and lines; current directory; todays’ date and time; amount of unused
memory and disk; and ASCII code of character under cursor.
4.6.2 Outline Display

Alt-V O displays the file in an outline format. Only lines that begin with a number
or letter in the left most column ate shown. The arrow keys are used to quickly scroll to the
desired line of the file. This command is most commonly used by C and Pascal
programmers.
4.6.3 Information about NE

Alt-V A displays information about the editor.
4.7 CONFIGURATION OPERATIONS

These operations sets or alters the configuration of the Norton Editor. Various
configurations are possible and the user can set a configuration in accordance with the
requirements. Various options under these operations are as follows:
4.7.1 Setting Display Configuration

Alt-O D sets display configuration including colour, number of screen lines, tab

width, enables the scroll bar, zoom display of dialog boxes, and blinking of matching bracket
when cursor right of )}] character.
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4.7.2 Setting Mouse

Alt-O M sets mouse configuration including selecting active mouse button, scroll
speed etc.

4.7.3 Setting Editor

Alt-0 K sets editor configuration including naming of backup files and operation of
Ins and Tab keys.

4.7.4 Saving Configuration

Alt-0 § saves cdrrent configuration settings.
4.8 GETTING HELP

Dialog boxes presenting help information are controlied by software buttons. Each
button is located near the bottom of the dialog box and is labeled with a word describing its
function. A button is pushed by either clicking on it using a mouse, or by pressing a key.
The key for most buttons is its first letter. Cancel buttons, which remove dialog boxes, are
always pushed with the Esc key.

Every dialog box has a default button that can be pushed with the_Enter key. Some
dialog boxes have several fields where information can “e set. The Tab and Shift Tab keys
are used to move the cursor to the field to modify. Then the space & arrows are used to
make the changes.

On the top line of the screen is a menu bar. To select an item in a menu, hold the
Alt key down while pressing the first letter of the menu name. Then press the highiighted
letter of the desired menu item.

KKK
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