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WINDOWS 3.1 AND ITS APPLICATIONS 

1.0 INTRODUCTION 
Microsoft Windows is a software program that makes the IBM PC easy to use. It is an 

operating environment. Usually the interface between the user and the computer consists of 

the screen and the keyboard; the user interact with the computer by responding to what's on 

the screen, typing the commands to do the work. Windows is just such a program. With 

windows, the user can run programs, enter and move data around and perform DOS related 

tasks simply by using the mouse or the keyboard to point at objects on the screen. 

A mouse is a small electronic gadget to communicate with the computer by moving around  

on the table next to the computer. The mouse may be used to select an item by moving the 

mouse pointer to that item and pressing & releasing the left mouse button. Also by double 

clicking the mouse over an item, the particular item may be selected. The mouse could be 

used to drag, maximize, minimize, restore, close or move the window, icons or items.  

Windows owes its name to the fact that it runs each program or document in its own 

separate window(A window is box or frame on the screen). The user may have a number of 

windows on the screen at a time, each containing its own program and/or document. The user 

may easily switch between programs without having to close one down and open the next. 

In Windows extensive on-line help is available to guide the user at various stages. It 

is a Graphical User Interface(GUI) combined with support of standardized methods. Instead 

of being a full operating system, Microsoft had originally developed Window 3.1 as an add-on 

over MS-DOS. However, the Window-95 has been developed as a full fledged operating 

system. 

2.0 NEED OF WINDOWS OPERATING SYSTEM 
Windows  (3.1 or 95) are being used very frequently to run many more technical and 

general use softwares. Some of the positive points of Windows  Operating System are as given 

below: 

Easy to use, having extensive on line help and graphical user interface(GUI) 

combined with support of standardized methods. 

Improved on line tutorial and help. 
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Capability of running several programs simultaneously. 

Switch over facility between multiple programs, 

User can communicate or exchange data between programs without transferring or 

copying files(using clipboard). 

Many specific purpose and utility programs are bundled with Windows  . 

Adjustable Font size and full mouse support for non-  Windows Applications running 

in a Windows. 

Screen saver facility. 

(I) Easier to use standard File dialogue boxes for opening and saving files. 

6) 
Screen and printer fonts are more accurate and easy to manage with new True 

Type fonts. 

(k) A "drag and drop" feature for some applications. 

(I) Using Dynamic Data Exchange(DDE) and Object Linking and Embedding(OLE) the 

pasted elements of one documented to the other remains 'live'. That is, if the source 

document (such as some spread sheet data) changes, the result will also be reflected 

in the secondary document containing the pasted data. 

3.0 REQUIREMENTS FOR USING WINDOWS  
Before using the Windows  , the user should atleast know about the DOS(Disk 

Operating System) commands such as copying disk, formatting disk, moving data files and 

printing files. Understanding of the actual process involved in these commands and several 

other DOS commands will help the user for working on Windows  . 
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To run the Windows software the user should have the following: 
An IBM PC AT-386/486/Pentium or compatible computer with atleast one 

megabyte of RAM. 

A harddisk with a minimum of five to eight megabyte of free space on it. 

640 k of conventional memory. 

1024 k extended memory. 

A monitor that is supported by Windows. 

A printer. 

A mouse for easy operation of Windows. 

One floppy disk drive. 

A modem if terminal is to be used for Windows application. 

4.0 STARTING WINDOWS 
To start the Windows, these steps are required to be followed: 

Boot up the computer in the usual way. ( oiAag )C)-5—P1.al  t CA) 

At DOS prompt type WIN and press enter. 

After few moments the Windows starting screen appears(as shown in Fig.1). 

Basically Windows startup screen has three basic parts; the c&al_p
cto , windows and icons. 

The pbi2QJs the overall work area(Window uses the whole screen). It helps in 

working faster and easier. To work over windows, the item are moved around the Desktop 
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using graphical representation of work projects. 

Fig.1: Windows Starting Screen 

To do some work on a specific program document, the mouse or key board is used 

and window opens on the Desktop. Windows usually starts up by displaying the Program 
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Manager window. Depending on the availability of the hardware, doing several tasks 

simultaneously is made easy through windows. For example, when the user switches from 

paint brush program to work processor he has to exit the painting program, go to MS-DOS 

and then start word processor. Leaving programs can be slow, starting programs usually even 

slower. With windows, switching between programs takes small time. 

Icons are the third basic element of the Windows  screen. At the bottom of the Program 

Manager window in Fig.1 several small symbols with names under them are visible. These 
are called icons.  Windows  uses icons to represent documents and programs when they are 

not currently opened up in a window. A special class of icon, is called a group icon, is used 

to represent a collection of programs that is grouped together for convenience(For example. 

Main, Accessories, Startup, Games are group icons of Program Manager). 

5.0 TYPES OF WINDOWS  

There are two types of windows in the Desktop: Application windows and Document 

windows. 

Application Window :  It contains programs that are running and working in a window, such 

as MS Word, Excel, PC Paintbrush, WP, and so on. Most of the work 

are being done in Application window. 

Document Window :  To work on more than one document at a time are Document 

windows. In MS Word the user can open more than one document file 

at once, in separate document windows. 

6.0 ANATOMY OF A WINDOW 

As shown in Fig. 2 a window has following parts: 

(a) The Title Bar such as Program Manager or Main.  It show the active window name 

if the user is working with many windows on the screen._ 
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Fig.2: Anatomy of a Window 

Minimizing, Maximizing, Restoring and Manually adjusting the window. They are the 

little control buttons to quickly change the size of a window. 

Scroll buttons(horizontal and vertical) to "pan across "the informations in a 
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window; up, down, left and right. This is necessary when there is too much 

information(text or graphics) to fit into the window at one time. 

Control Box is used for two purposes. First, it opens a menu, called the control menu. 

This is the same menu comes up when iconized window is single clicked. Most of the 

commands are to control the size of the window. Second, the control box for a 

program or document will be closed and iconized by double clicking on it. 

The Menu Bar which appears just below the Title Bar(lt appears only in 

application windows. Document windows do not have menu bars). It displays a number 

of options available in it. The user may select any of them using mouse or keyboard. 

When the Menu Bar is shown grayed or dimmed, it means that this choice is not 

currently available on you. 

Getting help. At any stage, the Help menu may be used for quick view of the 

commands and contents. 

Exiting Windows using control box or menu bar EXIT command. 

8.0 COMMUNICATING AMONG WINDOW PROGRAMS 
Two major methods for passing information are clipboard and OLE. Most of the 

interprogram communications is done through clipboard. 

Clipboard is a buffer or holding area in system memory that contains one piece of data 

at any one time. Read and write is done through standard commands. 

OLE is a method for passing data directly between programs without having to use the 

clipboard. It can be thought of as a telephone network on which one program can dial another 

program and pass certain types of information. 

9.0 ABOUT PROGRAM MANAGER 
Windows  Program Manager is a tool you can use to easily start applications, and 
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organize your applications and files into logical groups. It is the heart of the Windows. It is the 

part of the Windows that is always running as a window or as a icon, while you are using 

Windows. With Program Managers Commands, the user may run individual programs, switch 

between them, and copy material between windows. 

Program Manager starts every time the user start Windows. Each icon in the Program 

Manager window represents a group(as shown in Fig.1) and when a group is opened by 

double clicking the applications contained in that group are displayed in a window. The options 

and commands available with Program Manager are as given below: 

9.1 Arranging Windows and Icons 
Using Program Manager commands(Option menu), the desktop can be arranged so 

that windows and icons are easy to see. The Tile command resizes and arranges the open 

group windows side by side in the Program Manager window. The Cascade command resizes 

and layers open group windows so that each title bar is visible. 

9.1.1 To Arrange Group Windows On Your Desktop  

From the Window menu, choose Cascade or Tile. Use the Arrange Icons command 

to evenly arrange the icons in a group window. 

9.1.2 To Arrange Program-item Icons  

From the Window menu, choose Arrange Icons. You can also specify that Windows 

rearrange the program-item icons in a group window whenever you change the window's size, 

add items, or move items. 

9.1.3 To Rearrange Program-item Icons  

From the Options menu, choose Auto Arrange. A check mark next to the command 

means it is in effect. 

9.2 Changing an Icon 
If more than one icon is available for a program item, it can be changed. To change 

an icon following steps are required: 
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Select the icon required to be replace. 

From the File menu, choose Properties. 

In the Program Item Properties dialog box, choose the Change Icon button. 

If more than one icon is available in the Current Icon area, scroll through the icons by 

clicking the scroll arrows or by using the LEFT and RIGHT ARROW keys. If the user 

would like more icons to choose from, he can scroll through all the available Program 

Manager icons. In the File Name box, type cAwindows\progman.exe and then press 

ENTER. 

When the icon to be used is selected, choose the OK button. 

In the Program Item Properties dialog box, choose the OK button. 

9.3 Organizing Applications and Documents 

Using Program Manager, applications and files can be organised into groups. The 

following facilities are available: 

9.3.1 Changing Properties  

Once a program item or group is created, user can go back and change its properties. 

For program items, the description of the item, the working directory where files that the 

application creates are stored, the shortcut key you use for switching to the application when 

it's running, the icon that Windows uses to represent the application, and whether the 

application is minimized to an icon whenever the user start it can be changed. For a group, 

the description can only be changed. 

To change the properties of a program item or group the following steps are required: 

1. Select the icon for the item or group. 
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From the File menu, choose Properties. Or press ALT+ENTER. 

In the Program Item Properties dialog box, change properties as needed. 

Choose the OK button. 

9.3.2 Copying a Program Item 

When a program item is copied, the original stays in the source group. The user create 

a duplicate in the destination group. To copy a program item to another group the following 

steps are required: 

Select the program item to be copied. 

Open the destination-group window, or leave the destination group as an icon. 

Press and hold down CTRL while dragging the program-item icon from its current 

location to the destination-group window or icon. 

Release the mouse button and CTRL key when the copied icon is inside the 

destination-group window or on top of the destination-group icon. If the user 

release the mouse button and CTRL key when the icon is inside the source-group 

window, 

Program Manager creates a duplicate program item in the source group. The user can 

also copy a program item by choosing the Copy command from the File menu. 

9.3.3 Creating and Deleting Groups  

A group in Program Manager can be created or deleted to organize applications and 

documents. 

To create a group the following steps are required: 

1. From the File menu, choose New. 
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In the New Program Object dialog box, select the Program Group option, and then 

choose the OK button. 

In the Description box in the Program Group Properties dialog box, type a 

description for the group. This description will appear in the title bar of the group 

window and below the group icon. 

Choose the OK button. Program Manager creates a .GRP file for the group, so the 

user can leave the Group File box blank. 

To delete a group the following steps are required: 

Make sure the window of the group to be delete is reduced to an icon. 

Select the icon. 

From the Program Manager File menu, choose Delete. Or press DEL. 

In the Delete dialog box, choose the Yes button. Or press ENTER. 

9.3.4 Creating and Deleting Program Items  

A program-item icon represents an application, accessory, or document in a Windows 

group. By choosing the icon for a program item, user can start the application or accessory, 

or open the document. User can also create a program item by using a mouse to drag a 

program or document file from File Manager to a Program Manager group. 

To create a program item the following are steps are required: 

Open the group window that is required to be added. 

From the File menu, choose New. 
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In the New Program Object dialog box, select the Program Item option, and then 
choose the OK button. 

Fill in the Program Item Properties dialog box as necessary, and choose the OK 

button. 

To delete a program item from a group the following are steps are required: 

Select the icon for the item required to be deleted. 

From the File menu, choose Delete. 

Or press DEL. 

In the Delete dialog box, choose the Yes button. 

Or press ENTER. 

When the user delete an item from a group, it is removed from the group window, but not from 

the hard disk. 

9.3.5 Moving a Program Item  

The user can move a program item from one group to another. When a program item 

is moved, it is removed from the source group. 

To move a program item to another group the following steps are required: 

1 Open the group window that contains the program item to be moved. 

2 Open the destination-group window, or leave the destination group as an icon. 

3 Drag the program-item icon to the destination-group icon or window. 

4 Release the mouse button when the icon is on top of the destination-group window or 
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icon. 

The user can also move a program item by choosing the Move command from the File 

menu. 

9.4 Quitting Windows 
Program Manager is always running when the users are using Windows. The users 

quit Program Manager only when they are ready to quit Windows. 

To quit Windows the following steps are required: 

1 Quit any applications that are running. 

Make sure any changes made in documents or files are saved. 

2 From the File menu in Program Manager, choose Exit Windows. Or double-click the 

Control-menu box. A dialog box prompts the user to confirm that he want to quit 

Windows. 

3 Choose the OK button. 

9.5 Starting an Application 
There are several ways to start an application from Program Manager. To start an 

application, choose one of the following: 

Starting an Application by Using the Run Command 

Starting an Application by Using MS-DOS Prompt 

Starting an Application from a Group 

Starting an Application When the user Start Windows 
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9.5.1 Starting an Application by Using the Run Command  

The user can use the Run command to start an application that the user run only 

occasionally or have not yet added to a group. The user can also open a document at the 

time of start of application. 

To start an application by using the Run command the following steps are required: 

1 From the File menu, choose Run. 

2 In the Command Line box, type the path and name, including the extension, of the 

program file. The user can also specify the name of a document to open. For example, 

to run Microsoft Word and open a document named STATUS.DOC, the user would 

type c: \word \word.exe status.doc in the Command Line box. 

3 Select the Run Minimized check box if the application is to be reduced to an icon 

whenever it starts. 

4 Choose the OK button. Or press ENTER. 

9.5.2 Starting an Application by Using MS-DOS Prompt  

The user can start an application by using MS-DOS Prompt. From MS-DOS Prompt, 

the user can type MS-DOS commands. 

To start MS-DOS Prompt: In the Program Manager window, choose the MS-DOS Prompt icon. 

(Double-click it, or use the arrow keys to select the icon, and then press ENTER. 

To quit MS-DOS Prompt: Type exit and then press ENTER. To leave MS-DOS Prompt running 

and switch to the Windows desktop, press ALT+TAB or CTRL+ESC. 

Caution: Some MS-DOS commands try to modify part of the operating system that cannot be 

modified while Windows is running. Examples include the chkdsk /f and undelete commands, 

and certain other programs, such as Norton Speedisk. If the user need to run such programs 
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or use such commands, quit Windows first. 

9.5.3 Starting an Application from a Group  

If an application belongs to a group, the easiest way to start it is to choose the 

program-item icon in the group window. If the user associate a document with the program 

item, the document opens when the user start the application. 

To start an application from a group to following steps are required: 

Open the group window that contains the application's program-item icon. 

Choose the program-item icon. (Double-click it, or choose Open from the File ran) 

9.5A Starting An Application When The User Start Windows  

During Windows Setup, a StartUp group is created. When the user add an application 

to the StartUp group, the application starts whenever Windows is started. The user can add 

an application to a group by creating a program item, or by copying or moving an existing 

program item. 

9.6 Switching Between Applications 
There are a number of ways to switch between applications. The user can use any of 

the following methods. 

To switch to another application the following steps are required: 

Click anywhere in an application's inactive window. 

Press ALT+ESC until the window of interest is active. 

Press and hold down ALT while pressing TAB repeatedly to cycle through running 

applications. 
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When TAB is released, the application comes to the foreground. 

Press CTRL+ESC or double-click the desktop to open Task List. 

Select the application, and then choose the Switch To button. 

Or select the application, and then press ENTER. 

Choose Switch To from the Control menu of any running application. 

Choose the application's icon. 

9.7 File Menu Commands 

Use the scroll bar to see more commands(Fig.3). 

New : Adds an item to a group or creates a group. 

Open : Starts the selected application and opens an associated document (if there 

is one), or opens the selected group. 

Move : Moves a program item to another group. 

Copy : Copies a program item to another group. 

Delete : Deletes a group or item from a group. 

Properties : Changes the properties of a group or item. 

Run : Starts an application and opens an associated document (if there is one). 

Exit Windows : Quits Program Manager and Windows. 
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Fig.3 : File Menu Commands 

9.8 Options Menu Commands 

Use the scroll bar to see more commands. 

Auto Arrange : Rearranges the program-item icons in a group window 
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whenever it is required to change the window's size, add new 

items, or move items. A check mark beside the command 

means it is in effect. 

    

Minimize on Use 

  

: Reduces the Program Manager window to an icon whenever 

the user start an application (unless the application 

automatically starts as an icon). 

   

    

Save Settings on Exit 

 

: Saves the arrangement of Program Manager windows and 

icons when the user quit Windows. A check mark beside the 

command means it is in effect. 

   

9.9 Window Menu Commands 

Use the scroll bar to see more commands. 

Cascade : Arranges open windows so that the title bar of each window is visible. 

Tile : Arranges open windows side by side so that all of them are visible. 

Arrange Icons : Arranges into rows all program-item icons for a selected group or, if 

a group icon is selected, arranges all group icons into rows. 

List of Groups : The names of all your groups are listed at the bottom of the Window 

menu. To open a group, choose its name from this list. 

*** 
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